cancel
Showing results for 
Search instead for 
Did you mean: 

Leave request approval - Fiori

wobauer1
Explorer
0 Kudos
503

Hi all,

I try to configure the workflow for leave request approvals but at the moment my manager agent does not have the authorization to approve the request for my employee.

Error message:

You are not assigned to approve requests for this employee. You can only approve your own data.

Any idea where I have to configure it?

Regards

Wolfgang

Accepted Solutions (1)

Accepted Solutions (1)

siddharthrajora
Product and Topic Expert
Product and Topic Expert
0 Kudos

what backend role does the manager have? can you advise, you need to assign specific roles, you  ll have that in your installation guides

have you used ST01 trace to see missing authorization

1. Run the Approve app directly. (Not from Launchpad)

2. On browser, Inspect element, Go to network tab, call the app again

3. Find the last called OData service  /sap/opu/odata/..

4. Check the /IWFND/ERROR_LOG, Error context, Call stack

5. Set external break point and find the root cause

wobauer1
Explorer
0 Kudos

All authorization checks are green in ST01.

The following roles are assigned:

SAP_GBHCM_HR_APPROVAL_MANAGER

SAP_GBHCM_LEAVE_APPROVAL_MGR

SAP_GBHCM_LEAVE_REQUEST_EMPL

SAP_GBHCM_TIME_SHEET_EMPLOYEE

SAP_HCM002_HCM_LVRQ_CR

SAP_HCM003_HCM_LVRQ_APR

SAP_XI_CONTENT_ORGANIZER_J2EE

Here the error log:

Message: You can only change your own data.

During debugging I can see that the workitem id is empty. A function module is used to determine the agents but due to the missing workitem number it does not work.

If I do the request I can see the message - do you want to forward the request to Manager xyz. So the assignment should be ok.

Any idea?

Regards

Wolfgang

siddharthrajora
Product and Topic Expert
Product and Topic Expert
0 Kudos

is the workitem correctly routed to the above manager? Please can you confirm via SWIA or rptarqdbview report?

http://help.sap.com/saphelp_fiori/index.html#11f14195b3c944e4b8676194b14f205c.html

wobauer1
Explorer
0 Kudos

The error was because of incomplete workflow customizing.

Thanks for your help.

Former Member
0 Kudos

Hello;

I am facing the same issue. Could you please mention/advise what customizing you have changed in order to resolve this issue.

Appreciate your response.

Thanks,

Kapil Jhanji

adtoth
Participant
0 Kudos

please make sure that the swu3 settings are correct

Answers (2)

Answers (2)

adtoth
Participant
0 Kudos

Hi,

Can you please share your solution? I have the exact same problem and I cannot find the solution.

Thanks

David

Former Member
0 Kudos

Hello,

I am facing same issue. can you please share what you did to fix the problem?

Thanks,

Aravanan