cancel
Showing results for 
Search instead for 
Did you mean: 

IT0015 wage type is not caluclated problaby in payroll

Former Member
0 Kudos

Hi Experts,

I've a WT in IT0015 which takes input value as "Days"

when I enter 2 records for the same WT in the same month

in payroll simulation the first one has correct values. but the second record is missed up.

EXAMPLE:
---------------
in 01/2017 I've entered 2 WT of the same type

WT 9045 = 8 Days
WT 9045 = 2 Days

when I run the payroll the result is showing the first record has 8 days which is correct. but the second record is also set to 8 days... which should be 2.

here is the payroll result


and here is the pcr for WT 9045

when I remove the PCR from the schema. the result as days are correct.




what should I do in the PCR to fix this issue?

thanks

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member193210
Active Contributor
0 Kudos

First thing to look at would be the log of the processing (Payroll Simulation with the "Display log" box checked) in Function P0015. It should read IT0015, process both entries through a pcr (is it the one your have shown?), and transfer the result into the Output Table (IT).

What are the values for the Number field of WT 9045 in the Output to Function P0045?

What are the values for the Number field of WT 9045 in the Input (IT) to the pcr you have shown?

Former Member
0 Kudos

Thanks Remi,

Problem Solved,

I had to go again to processing class for WT9045 and I've disabled the Cumulation processing classes and it worked correctly.