cancel
Showing results for 
Search instead for 
Did you mean: 

Issue in defaulting the work schedule rule in QUOMO feature

Former Member
0 Kudos

Hello Experts,

I am unable to default the work schedule rule in the QUOMO feature under the Personnel Subarea as the error is showing as" The total field lengths of the decision operator are too great".Please help me to resolve this.

My requirement is basically to default the QUOMO rule based on the work schedule rule in a PSA.

Thanks&Regards,

M.V.V

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

What are the decision parameters you have used in QUOMO feature? Can you just paste your feature?

Regards,

Bhagyashree

Former Member
0 Kudos

Hi Bhagyashree,

Can you tell me how to paste the screenshot? I am unable to do that when I am using the option Insert Image..

Regards,

M.V.V

Former Member
0 Kudos

Create a .png file of the screen shot of feature. Click on Insert Image and follow the instructions.

Regards,

Bhagyashree

Former Member
0 Kudos

Hi,

Please find the issue screenshot.

Former Member
0 Kudos

I think field length of your work schedule is the issue. for this, go to PView, click on Table Maintenance. In column Variable Key, check the field length.

Check this.

Regards,

Bhagyashree

Former Member
0 Kudos

Or else in field selection for decision operation also you can check the field length.

Regards,

Bhagyashree

Former Member
0 Kudos

Also, double click on the error to get more details, and paste the same for further analysis.

Regards,

Bhagyashree

vianshu
Active Contributor
0 Kudos

Hi Vamsi,

This is an error similar to PCR where the maximum length gets exhausted and then you go for Sub PCR.

Please go sub feature functionality to write the remaining logic.

This will fix your issue.

Thanks and regards,

Vivek Barnwal

Former Member
0 Kudos

Hi Vivek,

Thanks for the reply. Can you plz elaborate on this if possible?

Thanks&Regards,

M.V.V

vianshu
Active Contributor
0 Kudos

Hi,

Please refer the below screenshots:

I hope using this process, you can resolve your issue.

Thanks and regards,

Vivek Barnwal

Sanky
Active Contributor
0 Kudos

Hi Vamshi,

Check your work schedule rule after SCHKZ decision operation.

Regards,

Sankarsan

Former Member
0 Kudos

Hi Sankaran,

The work schedule rule which I mentioned is right only.. The field length is also 8 which is sufficient for this rule .

Regards,

M.V.V

Former Member
0 Kudos

Hi Bhagyashree,

Thanks for the inputs,The filed length is 8 for Work Schedule Rule which is how I defined. Still this issue is there.

Thanks&Regards,

M.V.V

Former Member
0 Kudos

Please double click on the error for more clarifications.

Regards,

Bhagyashree

vianshu
Active Contributor
0 Kudos

Is this issue not resolved yet?

Regards,

Vivek

Former Member
0 Kudos

Hi Vivek,

How to create the subfeature initially? I have copied the existing feature & created but when I am trying to attach the same to the original feature it is saying the custom feature is not the subfeature etc.. Please let me know the process of doing both the steps.

Thanks&Regards,

M.V.V

vianshu
Active Contributor
0 Kudos

Hi Vamsi,

Please ensure that you have checked the sub feature checkbox for sub feature.

Go to TCode PE03, enter your subfeature and click on attributes.

Then click on struct. at the bottom. It will open a new screen. Check the checkbox for subfeature and then try to assign this feature to original QUOMO feature.

Let me know how it goes.

It would be good if share screenshot if you face an error.

Thanks and regards,

Vivek Barnwal

Former Member
0 Kudos

Hi Vivek,

I am facing the below issue in creating the subfeature when I am trying to fill the passing type.

When I am trying to save the subfeature, I am getting the below issue. I don't understand what this issue is & also why it is defaulting the return value as ZQUOM=01, 02 etc.. in stead of 01 & 02. Please help..

Thanks&Regards,

M.V.V

vianshu
Active Contributor
0 Kudos

Hi Vamsi,

For sub feature, please check only the subfeature checkbox. The passing type should be blank. Also, this subfeature will always be in saved status. The QUOMO feature will be in active status.

Let me know how it goes.


Thanks and regards,

Vivek

Former Member
0 Kudos

Hi Vivek,

Thanks all for your help. It is created with out any errors now..

Thanks&Regards,

M.V.V

Former Member
0 Kudos

Hi Vivek,

I had created the sub feature as mentioned & it was OK but while doing the testing it is saying the generation rules are not defined for ZQ which I had given in the feature. Please find below are the issues & the QUOMO feature. I have not at all given the grouping ZQ it was only 01 & 02.

Thanks&Regards,

M.V.V

vianshu
Active Contributor
0 Kudos

Hi Vamsi,

What is ZQ and for what purpose, you had given it?

Regards,

Vivek

Former Member
0 Kudos

Hi Vivek,

I didn't give any ZQ grouping. I guess it is taking from the feature QUOMO where in for 40(India) it is given as subfeature ZQUOM. But plz check in the ZQUOM feature should I give Q1 (As given by you) in stead of 01 & 02 etc.which I had given. Please suggest. Thanks in advance.

Thanks&Regards,

M.V.V

vianshu
Active Contributor
0 Kudos

Hey Vamsi,

I gave Q1 and so on because I had configured quota groups as Q1. At what stage of testing you are getting this error?

It would be good if you provide more information on this.

Btw...in my opinion, this is not an issue with the feature. Do you have quota by that code for which you are getting the error?

Regards,

Vivek

Former Member
0 Kudos

Hi Vivek,

I didn't anywhere give the grouping as ZQ but in the time evaluation run in the CUMBT Output SALDO table the annual leave is coming but in QUOTA Processing table Quota Type Selection rule is shown as ZQ.. Dont know how that is coming. I am in the processing of checking all the generation rules. Please find the below screenshots & suggest. Thanks in advance.

Thanks&Regards,

M.V.V

Answers (0)