cancel
Showing results for 
Search instead for 
Did you mean: 

Inter Company Transfer - OM Cost Center Error

Deon_van_Zyl
Active Participant
0 Kudos
465

Dear HR Org Guru's

We have a situation where we need to do an inter-company transfer for employee's but are receiving some errors we are unable to solve.

Facts:

* We have OM/PA integration switched on. The personnel area, sub area and cost centre in PA is pulled through from infotype 1001 (S - B007 - C) and 1008 on the OM side.

Problem:

When we try and delimit the current cost centre linked to the position on Infotype 1008 we get an error message "Entry is not allowed (due to K 0000000072 and P 08008074)" In this scenario the employee linked to the position is still in the old company code.

If you then try and approach this from PA side and try and transfer the employee to a different company code we get the following message "The CO account assignment object belongs to company code 1009, not 1040". This points us back to OM... which then again gives us the entry is not allowed error

So.. how do we solve this WITHOUT having to creating new positions and transferring the employees?

Kind Regards

Deon

Accepted Solutions (1)

Accepted Solutions (1)

harishtk1
Active Contributor
0 Kudos


Not sure whether this has anything to do with it, but is PLOGI EVENB set to X in T77S0?

Deon_van_Zyl
Active Participant
0 Kudos

Hi Harish,

Thanks for pointing me to the PLOGI switch!

I changed the switch and was able to create new entries in OM for Position linked to the new cost center and company codes.

When I go to the employee on the PA side it now mentioned (as in the PLOGI documentation) that the employee is locked via table 'T77INT'.

What would be the next step? Do I need to run RHINTE30? When I do, it does not retrieve the employee although when I run RHINTECHECK I get the cost centre inconstancies?

How should we proceed?

Kind Regards

Deon

harishtk1
Active Contributor
0 Kudos

If I remember correctly you should run RPLEVENT to remove the lock from table T77INT.

You should also check whether an suitable action type (for org reassignment) is maintained in PLOGI EVCCC prior to running this report.

Hope this helps

Deon_van_Zyl
Active Participant
0 Kudos

Brilliant! It worked!

I first had to delete the existing T77INT entry with function module HRWPC_PCR_DELETE_EARMARK and then updated the PLOGI EVCCC  to our Org Sync action, the redid the cost assignment and company change on the position and then ran RPLEVENT which created the action and now the employee has the correct cost centre, company code and personnel area's and sub area's.


If you lived closer to South Africa I would have sent you a bottle of wine!


Thanks a lot for all the help!


-d



harishtk1
Active Contributor
0 Kudos

That is great Gideon, Glad that it helped. This is what SCN is actually for.

Former Member
0 Kudos

Thanks Gideon for posting exactly what you did to resolve.

That helped me!

Answers (0)