cancel
Showing results for 
Search instead for 
Did you mean: 

Integration framework error on istallation

Former Member
0 Kudos

Hi experts,

We installed integration framework package but the installation finished unsuccessfully.

We tried to uninstall the package, delete %temp% folder, run cc cleaner to clean up the registry and windows installer Clean up utility, but we are getting the following message on the next installation:

“The version of SAP Business One Integration you want to install is identical with the current one. Installation is canceled. Please follow the user guide if you want to run on maintenance mode.”

Is there any specific key that must be removed from registry manually?

We are using SAP B1 9.0 PL04

Thank you in advance.

Kind Regards,

Vasilis Korolis

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hi Vassilis,

I've just delete this entry and the installation works:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun

2.0\Tomcat6

Regards,

David Almazán

Former Member
0 Kudos

Hi All

The Only way I found to bypass the issue was to install the B1 integration package PL05 with the rest components still on PL04.

Both mobile and dashboards works.

Former Member
0 Kudos

Hi Tushar Nathwani,

Thanks for the solution it works 100% for me.

Kind Regards,

Brenden Draper

Former Member
0 Kudos

Hi Vasilis,

I facing with this problem also. After rename the next registry entry: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun

2.0\Tomcat6

to Tomcat6_old the installation was smooth.

REgards,

Nghia

Former Member
0 Kudos

Hi Chi Nghia,

Thank you for your response. In HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0  Folder, there is no Tomcat6 folder or entry, only entries from SLD. I backUp the registry and delete the Apache Software Foundation Folder but the same message appears when i run the installer of B1ic Installation.

Any idea would be appreciated.


Best Regards

Vasilis

former_member203816
Active Contributor
0 Kudos

Hi Vasilis,

Please go through below SAP Note:

SAP Note : 1618978 - B1ic_Troubleshooting Guide for B1ic Installation

You are trying to re-install the Integration Framework but receive the following error: The version of SAP Business One

Integration you want to install is identical with the current one. Installation is canceled. Please follow the user guide if you want to run

on maintenance mode.

l Root Cause: Version not removed due to residual registry entries.

l Solution: Check the .com.zerog.registry.xml file located C:\Program Files (x86)\Zero G Registry (it is a hidden folder). If the file contains only

Integration Framework data, delete the file. If the file contains data for other programs along with the Integration Framework, only remove the

Integration Framework related components

Thanks & Regards,

Tushar Nathwani

Former Member
0 Kudos

Hi Tushar,

Thank you for your response.  I delete the file .com.zerog.registry.xml but the same message appears when i run the installer of B1ic Installation.

Any Idea would be appreciate.


Best Regards

Vasilis

former_member203816
Active Contributor
0 Kudos

HI Vasilis,

I already faced this issue & when I deleted this file after that it's worked fine...can you uninstall SAP B1 Integration from Control Panel Or delete the folder from program files ?

Thanks,

Tushar

Former Member
0 Kudos

Hi Tushar,

Thank you for you response. SAP B1 Integration is not visible on the control Panel (Add/Remove Programs) and I have already delete the Folder from Program files.

Best Regards

Vasilis

Former Member
0 Kudos

Hi.

I have the same problem, but i don´t have the Zero G Registry Folder, i tried to install the latest version of Integration and then it showed me this message " Upgrade is cancelled , database IFSERV is not available". What can i do ...i need to install Integration. Any ideas please??