cancel
Showing results for 
Search instead for 
Did you mean: 

ICR process for GL accounts.

Former Member
0 Kudos

Hi Ralph,

When i was trying to add the field GSBER for the GL reconciliation process in the standard transaction GCF2, the standard sap is giving me an error message "Fields GSBER doen't exist in FBICRC002T or FBICRC002A". In the current system, the business area is not being used, that could be the reason why we dont have it in the standard structure.Since i am new to the process, not sure of the consequences if we dont have the field GSBER.

Can you also tell me what is the need of this field.

If anyone had faced a similar issue, kindly can you help me on the steps of how to add this field.

Thanks in advance.

Regards,

Karthik

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Ralph,

I found a note 1355467 that was for the same issue of missing field RCOMP. Note has been applied and field is available in table now, but still I am getting the same error/dump even I did correct the table (FBRC003) by

- Choose "Select All" (F7).

- Choose "Delete" (Shift+F2).

- Confirm the dialog box for the deleted entries.

- Save the settings.

- Choose "New Entries".

- Save the settings again.

Still No luck. Any advice?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Ali,

Is the field catalog maintained for your current process? If you go to transaction FBRC008 and select the field catalog for your process is there a message that some settings were corrected automatically? If so, you need to save before leaving the transaction. It is possible that currently the field RCOMP is not set up correctly in your field catalog which would cause the runtime error.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

Thanks a lot for your response. It has been resolved as per the instructions.

Appreciated.

Shahid Ali

Former Member
0 Kudos

Hi Ralph,

I have another critical issue in ICR2. In FBIC009 - companies to be reconciled (Attributes per company code), I could not select File Upload as it is greyed out, even though Structure FBICRC_S_UPLOAD exist is our SAP system (SAP note 1366967-ICR: Upload structure FBICRC_S_UPLOAD is missing - does not apply to us) and upload file option is available for ICR3 process in FBIC032. It is just not available for ICR2 process. Please advise?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Please implement the corrections according to note https://service.sap.com/sap/support/notes/1384934.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

Thanks for your repsonse and help. Our basis team is looking into that note and in process of applying it. In the meanwhile I did make some postings and now seeing only one issue as follows;

For ICR2 process - In FBICA2 - Assign Documents - I clearly see my 4 documents posted and getting selected for a particular date i.e. 05052010 in the TEST RUN. but once I execute without TEST RUN nothing gets displayed in the report and all blank? Any suggestion if I am missing something?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Are there any runtime errors logged in ST22? Did you maintain the number range for the reference numbers? Depending on which corrections have been applied the corresponding error messages may not be shown yet...

Ralph

Former Member
0 Kudos

Hi Ralph,

No run time errors, but I just noticed that it is working for one company code combination but not for the other i.e., between US and Canada it is not working but for US and Puerto RIco it is working. Any idea as all the configs are same for all the company codes.

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

If there are no runtime errors in ST22 and it is working for some of the business partners then there is nothing I can think of at this point. I suggest you create a service ticket.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I did further analysis and found out that REFDOCNR is not the same like accounting DOCNR. It used to be the same in our Sandbox where I tested it and Rule for asignment was REFNR=REDOCNR and everything was fine there. But now looks like it is not going to work in testing box where REFDOCNR is not equal to accounting document number. Any specific reasosn why they are not same anymore even though they are FI generated documents.

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

REFDOCNR is a reference to the original document. If the original document is posted in FI then it will be the FI document number. But if the process originates from SD, MM, ... it will not be the FI document number.

So when you were saying that automatic assignment was not working you meant that you were not getting the assignments you were expecting, correct?

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

REFDOCNR is not equal to FI document number generated in my case for FI documents posted. They are totally 2 different numbers now. That is what the problem I am having currently in Testing box. Earlier, In my Sandbox it was working fine and still working fine where both Accounting doc and REFDOCNR were getting the same number and I used the rule REFNR = REFDOCR. since it is not working in Test box, I can not use the rule REFNR = REFDOCNR. Any step or thought why I am not getting same REFDOCNR as DOCNR or if I am missing any step?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Since this is process 002: have you checked field FAGL_DOCNR?

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I tried REFNR = FAGL_DOCNR, still no luck. it even stopped showing the other patrner's data in unassigned protion in FBICR2. i believe ICR 002 would work only if REFNR=REFDOCNR, but in my case my Acccouting doc is not in sync with REFDOCNR and that is causing the issue. Is there any way i can fix that issue of havign same FI doc number and REFDOCNR?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Please check the information in the FI document. What is the reference number there? It should be the same one that is also transferred to the SPL document.

You may have to create a service ticket to get this resolved...

Ralph

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Apparently you are posting directly to the SPL. When you do this then the FI document number is not yet available when the SPL document is posted. This is why REFDOCNR cannot contain the FI document number. If you depend on REFDOCNR containing the FI document number you need to set the posting indicator for your SPL to 2 and post the data subsequently using transaction GCU1.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I post first in our main Ledger (using Fb50) and since I have setup Ledger in such a way that everything that is RFBU is moved to ledger at the same time. Even the same configuration was done in our sandbox where we never had that kind of issue. Now that issue is a show stopper for GL reconciliation as I cannot reconcile anything even using any other rule as I have incorporated a user exit that add zero in our reference field to make it like RefDOCNR digits same. Looks like we applied 2 notes in to the sysytem and that imay be a side effect of them. Any way the SAP support ticket has already been raised and looks like you are working on it. I want to post to ledger and recon ledger at the same time so that users do not have to do seperate step of doing GCU1.

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

As I mentioned in the service ticket:

If you need the FI document number but you want to post to the RCL ledger directly you need to run FBICRC002_DOCNR_SELECT before running FBICA2. That way the FI document number is added in field FAGL_DOCNR which can then be used in FBICA2.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

Thanks for your earlier response and FAGLDOCNR works for us now. But I have been notified by our FI team that they are not able to post any FI documents in prior year i.e., 2009 etc. They raised a service ticket for that and finally got a note from SAP i.e., "since in the system you have ICR Ledger I2 assigned to company code U001. You can see same in GCL3. In the totals table for FBICRC002T/A there is no entries in 2009 for ledger I2. In ICR it is important the For process 002 the right account

number must be transferred to ICR field RACCT even in the sender ledger, because there´s only one account field in the database table."

But my question is how we can fix it as in the GCL1 I have created only one transaction RFBU as per your eariler instructions and have the same following field movement as show below; and that is working fine with the exception now we cannot post any document in prior year and get a hard error message (group account does not exist in company code chart of account).

Field mvts are as follows

DOCDT Document Date ACCIT_GLX BLDAT Document Date

GSBER Business Area ACCIT_GLX GSBER Business Area

RACCT Group account number ACCIT_GLX ALTKT Corporate group acct

RASSC Trading Partner ACCIT_GLX VBUND Trading Partner

REFNR Reference Number ACCIT_GLX XBLNR Reference

Should we use any other field instead of RACCT in combination with ALTKT ? Please Advise?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Assignment of operative accounts to group accounts is not time dependent. Therefore I do not understand why you would not be able to post into previous years.

If you do not have group accounts set up you can also fill RACCT with the operative account number HKONT. If you do not have to integrate data from different CoAs and/or your object groups do not require group accounts this might be a solution for you.

BTW - I am not sure whether you only need RFBU as the only activity. Usually the recommendation is to use the function Acitivities Like G/L. This is also described in the IMG documentation (in the branch Preparations in the Sender System.)

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

We do use group accounts that is why cannot use HKONT. Also we got this message from SAP

"You could in GCL2 temporary block posting for ledger I2 in company code U001 while you post this document and then change the Blocking indicator back to 1 after this posting."

That did work and allowed us to post in back dates but that is not a viable solution to us as we do not want to move config back and forth during year end processes. Is there any other way we can get this resolved?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

What is the service ticket number?

Best regards,

Ralph

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

I had a look at your system and the problem is that you assigned the wroing chart of accounts to the company for the ledger. You assigned CoA KF01 although the group CoA is KF00.

GCL3 >> double click I2 >> Company Assignment (F6) >> double click U001

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

Customer Message Notification - 450585/2010.

Thanks,

Shahid

Former Member
0 Kudos

Hi Ralph,

Customer Message Notification - 450585/2010.

Thanks,

Shahid

Former Member
0 Kudos

Hi Ralph,

Customer Message Notification - 450585/2010.

Thanks,

Shahid

Former Member
0 Kudos

Hi Ralph,

We have successfully moved our Config from Dev to Quality and everything is working fine during testing except this new weired issue. In FBICR2 (GL Recon) - if all items get reconciled (so no Unassigned item available for that particular period), then report does not get displayed and every thing is blank...... but when we post another document that would stay unreconciled (as we do not post the other offsetting entry in Trading partner company code), Reort (FBICR2) starts showing all earlier Assigned and new one unassigned documents. Hence this is very tricky why it stops working when all entries are assigned and none is unassigned? If again I post the other document in Affiliate company code to reconcile this unassigned one.... I can see clearly in FBICA2 that this one also gets assigned ... and no unassigned in the message and then rerunning FBICR2 will show us nothing. Looks like we must have to have atleast one unassigned document to have it displayed which is not a good way to go! Is there any OSS note for this kind of issue or any config that I am missing? Your help in this regard would be highly appreciated? And the reason why it could not get traced in Development becuase we always had so much data in EWD hence always had Unassigned items hanging in there with Assigned ones.

Thansk,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

ICR is geared towards analysis of differences. If there are no differences then there is nothing to do. This is why business relationships where everything is reconciled are not shown per default.

But if you look at the toolbar of the tree overview there are different colored LEDs there. Per default only Yellow (Unassigned Items Exist) and Red (Differences Exist) are shown. If you also push down Green and/or Grey then additional items will be added to your tree.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I tried pushing down Green and/or Grey but in them No datat record selected message is coming. I used to see earleir in green all items that got reconciled in Developement box but not in Quality box any more? Any thing that I am missing? or it would not show at all anything if everything is reconciled and no unassigned item exists?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

If there are documents for the time frame you are working with and all of them are assigned then they should be shown with status Green.

Ralph

Former Member
0 Kudos

Hi Ralph,

I did post some Cutomer (Fb70) and Vendor (FB60) inovices with first's document number as a reference in second. Both got posted but the problem is they are not showing up in FBICR3 at all. Then I looked into the "Auxiliary Program" and in the List of "Total Record" I saw them in the list of documents available but with Status RT 2 - Assigned documents need further clarification. I am not sure why they are existing in List of records but not being displayed in Reconciliation Program FBICR3? Even if they need some clarification or has some confusion still they need to show up? Please let me know how can I resolve this and how we can change the status of these documents and atleast to bring them over to FBICR3 display area (does not matter if they are assigned as we would manuallly assign them). FYI, I did see them (documents) in GL Reconciliation - process 002 - FBICR2 reconciled to each other properly and we are fine with it but for AP/AR recon they should also show up in process 003. Please advise!

Thanks,

Shahid

Former Member
0 Kudos

Hi Ralph,

I am working with Karthik on this and ICR process 002 is still not working. After going through all the SDN notes and applying every thing in SPL area and NEW ICR process 002 (all the validation in SPL has been done, same sender and reciever ledger selected, tested all activities like GL and also RFBU transaction seperate, field movt structure is as per your suggestion for which we added also GSBER in above questions etc) still we are not getting the data selected that gets posted manually. Same old message "No Data selected according to the specified restrictions". What else could be the reason? or Do you you have any White Paper that we can compare our configurations with. FYI, our another ICR Process 003 for AP/AR is working fine already.

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Are you saying that the initial posting is not transferred to your SL? In that case I recommend you analyze this using transaction GCD1. If the sender and receiver ledger are the same then FBICS2 is irrelevant and should not be run. Other than that I suggest that you create a service ticket...

Ralph

Former Member
0 Kudos

Ralph we are setting up Process 02 but for some reason table V_FBRC0020 IS GREYED OUT and do not allow you to change the setting on the table. i look for a oss note and comments in the forum for answers but i can not find the caue for the issue

Johannes

Edited by: Johannes Le Roux on Jan 13, 2010 12:49 AM

Edited by: Johannes Le Roux on Jan 13, 2010 12:50 AM

former_member572578
Active Contributor
0 Kudos

Hello Johannes,

Most of the role assignments in FBRC008 are fixed - therefore you cannot change the default roles assigned to individual fields. You should go into the view and save at least once though if you get a message that some assignments were changed automatically. You should only be able to change the role assignment for self-defined fields.

Best regards,

Ralph

Former Member
0 Kudos

Thanks for the reponds - I Understand what i do not undestand is just the NEW GL ROLE Lines is open for change all the other lines is greyed out and you can not do any selections.

former_member572578
Active Contributor
0 Kudos

Hello Johannes,

The FAGL fields were added later on and I forgot to make the role assignment unchangeable in the view maintenance. However, with these fields it also does not make any sense to change the default role assignment "Subassignment".

Best regards,

Ralph

Former Member
0 Kudos

Thanks again we do not want to match on REF Number i want to change to match to REF KEY - So how can we change the table to allow changes to the roles .If the NEW GL update OSS notes caused the change can you correct and give a OSS note to apply to fix and allow updates to table v_fbrc0020.

former_member572578
Active Contributor
0 Kudos

Hello Johannes,

Please note that the role assignment in this view only designates in which field the technical key is stored which ties documents to a document group. You can define your rules independent of this customizing.

Ralph

Former Member
0 Kudos

Hi Ralph,

Our ICR 002 process has started working without creating a support ticket and it is reconciling the GL documents. But we are faced with some new issues as follows;

1) In u201CDefine Rules for Document Assignmentsu201D t-code FBRC005, when I use REFNR=DOCNR, it does not work at all for ICR002 as it is working only in our process ICR003. As we are posting in company code suppose 1000 and whatever document number gets generated here we use this number in the Reference of other Company Code say 2000. So it does not get assign. But when I change the rule to REFNR = REFDOCNR then it starts getting assigned as in the tables both REFDOCNR value is the same like DOCNR. What is the issue here? Should we always use REFNR = REFDOCNR? Or there is something we are missing that prevents us using REFNR=DOCNR rule?

2) When we are copying the Document Number in to the Reference field of the other company code. It copies the number without the u201CLeading zerosu201D as usual i.e., 1234567 instead of 01234567. And that does not work for process ICR002 and we have to put in 0 as a leading zero and it starts assigning properly. Without u201C0u201D it does not assign it. But this issue is not happening in ICR003 process and documents get assigned without putting leading zeros there. I have tried configuration in t-code FBIC010 by checking the u201CConvert Document Number (Delete Leading Zeros) as well but no luck. Do we have to put in u201C0u201D always? Or configuration in FBIC010 is only for REFNR=DOCNR only and would not work for REFNR=REFDOCNR. (I have tried putting leading zeros as well for the rule REFNR=DOCNR but that does not work as well and nothing gets assigned).

3) We are not able to u201CDelete Transactional Datau201D in Auxiliary program for GL (for FBICR2) - Data Record Administration as nothing gets selected/deleted. And Documents reconciled earlier staying there forever. In our configuration we have same Sender and Receiver Ledger. But For AP/AR process (FBICR3) it works fine and we are able to delete transactional data and reselect them while running step 2 assign and step3 Reconcile documents. FYI, here in ICR 003 we only use one ledger in Receiving ledger. How can we fix this issue of Deleting Transactional Data in process ICR002?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Re 1) It is standard FI-SL functionality that documents posted into a SL are assigned a new document number. REFDOCNR will only contain the corresponding FI document number if the document originates from FI. Otherwise this might be a SD, MM, ... document number. If you want to be sure that you are dealing with the FI document number you would have to run program FBICRC002_DOCNR_SELECT and use field FAGL_DOCNR.

Re 2) If you want the leading zeros to be deleted you need to implement this in a user exit in your field movement.

Re 3) If the auxiliary program does not work you can also use transaction GCDE - which will also clean up the index tables.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

For leading Zeros to be deleted, I have implemented user exit and it is working fine now. Thanks for that info. I am still working on previous issues but I have another issue that I forgot to address last time. For some reason, I am not able to view Display Original Documents in "FBICR2" in Assigned Data Record section at the bottom of the page (last section). I do see them reconciled in the "Without Difference" area and all other related info/fields in ALV format but when I want to jump back/drilldown to original documents (to see Both FI docs like it is working fine for AP/AR only) by selecting that line and pressing Document Display Button, system gives me message "Selected Document could not be displayed". Please advise what could be the reason and how we can fix that issue?

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

There are several notes available - as far as I know if you apply all of them it should work...

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

Thanks for your earlier response. I have two quick issues that need your attentions as follows;

1) I could not find any Note for the issue of Displaying Original Documents in "FBICR2" as we are on latest support package i.e., SAP_APPL 604 0004 SAPKH60404 Logistics and Accounting. Do you know any SAP note that could be applied as all other notes are old and not applicable to our system?

2) I have tried using transaction GCDE - for clean up the index tables, but after I have used it my step 3 in FBICR2 (reconcile documents) has stopped reconciling the documents and error message that I get is "no unassigned document; nothing to display". In Step 2, "Assign Document" I see clearly my documents getting assigned and even in Transaction Tables I see their existance. So why they are not showing up in Step 3 "Reconcile documents"?

Please advise.

Thanks,

Shahid

former_member572578
Active Contributor
0 Kudos

Hello Shahid,

Re 1) In this case I recommend you create a service ticket.

Re 2) Run the auxiliary program to recalculate the totals. Maybe those are not up to date yet. The totals records are used to create the overview display in FBICR2 - the program does not read any line items at that point. If recalculating the totals should not work you should create a separate service ticket for that issue.

Best regards,

Ralph

Former Member
0 Kudos

This message was moderated.

Former Member
0 Kudos

Use field RBUSA.

Former Member
0 Kudos

Hi,

The field RBUSA is not available in the system.

Thanks,

Karthik

former_member572578
Active Contributor
0 Kudos

Hello Karthik,

Which transaction are you using? You should be adding fields using transaction FBIC006.

What is your release, EHP, SP level?

Best regards,

Ralph

Former Member
0 Kudos

What is your release - 700 (ECC 6.0)

EHP - SAPKB70015

SP level - 15

former_member572578
Active Contributor
0 Kudos

Hello Karthik,

Do you get the error message in FBIC006? If not, which transaction are you using? What is the error number (e.g. FB_ICRC045)?

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I am providing teh details which you had asked for.

"Field RBUSA does not exist in FBICRC002T or in FBICRC002A

Message no. GG224

Diagnosis

This field does not exist either in the summary table or in the respective single-item table and therefore cannot be used in the field assignment".

I also have few questions based on this.

Is that Field "Business Area" a must field to have in this config to have this Recon Program working properly so that it will start selecting documents? If Yes then how we can get this field populate here?

If No, then what is there work around or what else field can be used?

Thanks in advance.

Karthik

former_member572578
Active Contributor
0 Kudos

Hello Karthik,

Actually you only answered one question out of the three I asked... But from the message it seems that you are trying to set up the field movement for your ledger.

#1 You need to first add field GSBER to your ICR database. If you want the field to be available in totals reporting you need to add it with availability Totals Records: Subassignment. Otherwise you should add it with availability Line Items: Subassignment.

#2 Afterwards you have to activate the changes by running FBIC004 in update mode.

After you completed both of these steps you can add the field to your field movement.

Best regards,

Ralph

Former Member
0 Kudos

Hi Ralph,

I have added the field GSBER in 'CI_FBICRC_002_SITEM' and then after that i was able to add the field GSBER in the field movement in transaction GCF4.

Kindly can tell whether this is the correct approach.

Thanks a lot.

Karthik

Edited by: karthikeyan devakumar on Nov 25, 2009 5:18 AM