cancel
Showing results for 
Search instead for 
Did you mean: 

How to perform auto UD in background for batch stock?

Former Member
0 Kudos

Hi All,

How to perform auto UD in background for batch stock?

Regards,

Sameer Jalal

View Entire Topic
Former Member
0 Kudos

i m working on qa41 and will see if it helps...

thanks

Former Member
0 Kudos

hi guru's,

i have tried using qa41 for the background ud and posting of batches but after making a varient when i perform a job, session does'nt start itself, and batch status remain rel calc sprq, where as my requirement is rel calc spco.

help me.

Regards,

Sameer Jalal

former_member42743
Active Contributor
0 Kudos

You usse QA10 to set up the variant.

Use QA17 to set up the job.

In the material master for the inspection type, (04 in your case it sounds like), set the tick box "Auto UD allowed"

In the UD code being used, set the tick box "Stock screen backgr." (QS51)

This will post those batches where all characteristics are accepted and have a closed status of 5.

In teh QM plant config, check the UD wait time and make sure that lot being used for testing, meet the wait time requirement.

FF

Former Member
0 Kudos

varian made, job assigned, tick box "Stock screen backgr." (QS51) done,

but still error seen is something like that (No batch input data for screen SAPLIPW1 0200). it doesnot allow me to perform an operations of my need.

Former Member
0 Kudos

whatr does this error means?

former_member42743
Active Contributor
0 Kudos

It basicaly mean the batch job that run had no data provided to it.

Try this,

Create an inspection lot, record all results in spec, close all characteristics so they have a status of 5. Then go to the UD (QA11), and select the UD code and save. If the stock is posted then everything should work. If the stock is not posted, then you have a problem with your master data setup.

If the above works, create a new inspection lot. Record results and close as described above. Instead of making the UD, run QA10 manually for the material. If it fails, you have something wrong in the variant.

If it works, repeat again and run in batch. If it fails in batch mode, you have a problem with the batch job setup. Talk to the Basis people.

FF

Former Member
0 Kudos

dear all,

as far as i came to know batch job in background for ok lots is performed by use a T-code qa41,qa40, qa 42.

production lot/ bacthes cannot be done on qa16 as qa16 only allows us to perform ud and posting for the 01 region while i need to do ud and posting for the 04 region batches..

Regards,

Sameer Jalal

former_member42743
Active Contributor
0 Kudos

I'm not sure what you mean.

QA16 should work with both 01 and 04 inspection lots. It is interactive and not meant to be run in batch.

QA10, QA17, QA18 transactions are used to set up and process automatic usage decsions for most all inspection types except 03 lots. This included both 01 and 04 lots.

The QA40, 41 and 42 series of transactions is for processing 03 inspection lots from production.

FF