cancel
Showing results for 
Search instead for 
Did you mean: 

How to cancel a formatted search

Former Member
0 Kudos

We have a UDF on the sales order line whose value is assigned by a formatted search triggered when the Factor2 value changes. This has an unwanted side-effect. When an existing sales order is retrieved, B1 triggers the formatted search for the blank grid line, the associated query returns a value, and B1 switches the form to Update mode, yet the sales order itself hasn't changed. Is there some way of preventing this? (In B1 2007, we discovered that B1 wouldn't update the UDF if an error occurred in the query. We used this knowledge to work around the problem. This still works in B1 8.8, however B1 displays the SQL error in the status bar.)

Thanks for the help.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

If you set auto refresh and the field value changed, you have no control to cancel FMS query. You have only 2 options:

1. Set FMS to manual without auto refresh

2. Allow the current FMS auto refresh

Answers (2)

Answers (2)

keith_taylor2
Active Contributor
0 Kudos

Just to make sure is the factor 2 field before the field that has the formatted search in the grid? If not it should be

Former Member
0 Kudos

Yes, it appears several columns to the left of the UDF column in the sales order line grid.

keith_taylor2
Active Contributor
0 Kudos

If all you want to do is cancel the formatted search do the following:

Go to the field where the search is applied.Enter Ctrol-Shift-F2. A small window will be displaed. Click on the radial button at the top "without search". Update and save the screen. The formatted search will now be non-fucntional

Former Member
0 Kudos

Thanks for the reply.

We don't need to completely disable the formatted search, rather we need to either prevent B1 from triggering it for the blank sales order line or somehow cancel it once it has been triggered so that we can avoid the side-effect mentioned in my posting.

Former Member
0 Kudos

Have you set FMS to auto refresh? If so, change to Display Saved Value.

Thanks,

Gordon

Former Member
0 Kudos

Thanks for the suggestion. It behaves the same regardless of whether Refresh Regularly or Display Saved User-Defined Values is selected. (For the record, 'Auto Refresh' is checked and 'When Exiting Atlered Column' are selected.)