cancel
Showing results for 
Search instead for 
Did you mean: 

How to activating Widgets in B1 Cockpit

Former Member
0 Kudos
3,191

Dear All,

I would like to know that has anyone have experiment in SAP Business One PL12 Cockpit feature? I need help in setting up B1i Server Address for Dashboard's Widgets.

Thank you in advance.

Nghia

View Entire Topic
Former Member

I've installed sap 8.8 PL12 and afterwards the SAP Integration Solution for B1

Folowed everystep, tested the connections in SDL, everything OK, url in cockpit configuration is correct. But I keep getting the folowing error in the dashboard widget:

404-Not Found

Internal Reason

/com.sap.b1.dashboards/001sap0001.SAP_Dashboard_001.DAB003/default.html

I've tried as mentioned in this thread to deactivate it and reactivate again several times, it doesn't go away.

Do I need Xcelcius for the dashboards to work? (I starting to get lost here.., )

Former Member
0 Kudos

Hello NuNo,

You do not need xcelsius.

Please read the thread carefully and check everything. It should work.

Regards

János

Former Member
0 Kudos

double checked everything...

- SDL test connections says it's everything ok.

- the url in configuration is exactly the same as in the instalation guide pdf (replacing <server name> to localhost and windows machine name getting the same result)

- The checkbox for trusting the server tried both ways checked and unchecked.

The Webserver Tomcat reporting 404 is very wierd.. Tried reinstall, same problem. What am I missing?

Any ideas?

Former Member
0 Kudos

Dear Nuno,

check if the Windows Services SAP DIProxy und SAP DI Proxy Monitor are runnning.

If They do not run, start the services, afterwards deactivate and reactivate widgets.

Former Member
0 Kudos

Thanks for the reply. Yes they are both running, SAP Business One DI Server too.

Former Member
0 Kudos

Hello All,

Question to people who the widget not running:

-Which SQL version are you using?

-Do you have a named SQL instance installed for 8.8 or are you using default instace:

- did you checked the licenses, that has to be applied?

named sql instance example: : (local)sqlexpress, default instance: (local)

Regrards

János

Former Member
0 Kudos

Thanks János,

Now my widget working in the root. I have a problem with the sub instance too.

Pretty nice looking dashboards :).

Nghia

Former Member
0 Kudos

I'm using SQL Server 2008 default instance, all licenses ok.

But.. finally solved! De-activated not only the widgets, but all cockpit, restarted every services, and reactivated cockpit.... SOLVED! finnaly! Hopefully it won't happen again later in the production enviroment