Showing results for 
Search instead for 
Did you mean: 

How do I make Payflowpro work?

0 Kudos

Hi all,

I'm setting up the company website. We use payflowpro as our gateway.

I've setup it up in webtools, and I can get a dummy card to work on the test site, but when I switch it to live and test it with a real card it says "Credit card not authorized."

When I go to the credit card website, there is no record of denying the card, so the website is never communicating with the CC site.

When you do a dummy card on the test side, everything works fine.

Any ideas on how to fix this would be greatly appreciated.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

You also need to change the URL it's posting to.

If that doesn't work try

0 Kudos

Where do I find that url?

I've been through the database, and anything that looks like a file that might hold it. Where is the url stored?



Former Member
0 Kudos

It's on the gateway details page in the admin. In the same place where you put the userid and password.

0 Kudos

Hi Bryce,

I hate being stupid, but I don't have a spot for a url. Here are the fields I have...


Test Mode:..........unchecked

vendor code:........our company code

User:...................our company code




Firewall Type............NONE

Firewall Port.............8080

Firewall User ID........blank

Firewall Password.....blank

Firewall IP Address...blank

With this setup, if I check the "test" box, everything works. Uncheck it, nothing works. I get the following error message:

"Credit Card Not Authorized (Failed to connect to host Input Server Uri)"

Sorry to be dumb, but I'm not sure how to fix this still.

Former Member
0 Kudos

Was the same payflow account used for live transactions before?

It might be that payflow gateway is rejecting live transactions

0 Kudos

Yes, I am using the same credentials that we have been using since you set it up in netpoint originally.

I also have a credit card app that I wrote that we use everyday using these settings.

You talked about changing the http: to https: To me it looks like that is hard coded somewhere. Is it possible the wrong url was used, causing everything to be rejected?

I've searched the entire database, and I can't find any reference to a url for the ccgateway. That makes me think it was hard coded.

I did notice that I am using a newer version of the payflowpro dll. BUT, the credentials haven't changed in 3 years.

Any other ideas?

Former Member
0 Kudos

Jim can you post your version info from the about.aspx page?

0 Kudos


Serial No. removed

Organization removed

Customer No. removed

User removed


Assembly NPBasePage






Constraints MachineName: JOSHUA

MachineID: removed

Domain: localhost

LicenseType: Demo

Focus: True

ECommerce: True

StartDate: 2009-02-23 00:00:00Z

EndDate: 2010-02-23 00:00:00Z

MaxNamedUsers: 10


NetPoint 2007.1.651.1

NetPoint.API 2007.1.651.1

NetPoint.CreditCards 2007.1.651.1

NetPoint.WebControls 2007.1.651.1

Web Tools Database 651


Server Name JOSHUA

Web Tools Memory 76 MB

OS Version Microsoft Windows NT 5.2.3790 Service Pack 2

.NET Version 2.0.50727.3053

MDAC Version 2.82.3959.0

Current Variables

Server ID removed

Encoding en-US

Catalog Code Web

Virtual Path /

SQL Database

Server Name JOSHUA

Language us_english

Version Microsoft SQL Server 2005 - 9.00.3042.00 (Intel X86) Feb 9 2007 22:47:07 Copyright (c) 1988-2005 Microsoft Corporation Standard Edition on Windows NT 5.2 (Build 3790: Service Pack 2)

Appl. Name .Net SqlClient Data Provider

0 Kudos

Hey Bryce I just had a thought...

There is another post asking about payflowpro certs paths.

I have been assuming webtools is set up to use payflow pro. Is there something I need to install to get it to work?

I'm thinking no, since the test side uses the same dll, but I thought I'd ask.

Former Member
0 Kudos

With SP1 you don't need the certs path as it uses the new payflow dll.

I'm having the same issue as you with the test/live switch. I'm investigating further.

Former Member
0 Kudos


Looks like it is posting to the wrong URL when in live mode.

You can override this by adding a row to the web config table.

1. open SQL Server Management Studio

2. run script on WT database (to override default URL):

INSERT INTO WebConfig (App, UserName, Pwd, ConfigKey, ConfigValue, DataType, Description, Choices, UILabel, SortGroup)

VALUES ('netpoint.paymentprovider.PayFlowProGateway', 'local', 'local', 'URL', '', 'string', '', '', 'URL', 'common')

3. create order using PayflowPro gateway

0 Kudos

That fixed it. You're a hero!

Thanks for the help.


Former Member
0 Kudos

What no points?

Answers (0)