cancel
Showing results for 
Search instead for 
Did you mean: 

How do I edit an existing Validation?

Former Member
0 Kudos

Hi,

I need to edit a existing validation in place. There several steps to that validation.

The current validations reads as ( BKPF-BLART = 'SA' AND BSEG-HKONT IN ZSPL_VALID_TP I need to add another document type in addition to SA. Can someone tell me how do i go about doing this?

I tried going to insert & edit but it seems to add. Please can someone help me.

Thanks

Noopers

Accepted Solutions (1)

Accepted Solutions (1)

former_member182098
Active Contributor
0 Kudos

Hello,

Go to GGB0 - Double click on your rule

Click on OR

again double click on BKPF-BLART

Click on Constant

Enter your additional document type

Both the document types will get included.

Regards,

Ravi

Former Member
0 Kudos

Hi Guys,

Thank you for the answers...very helpful. This is finally what my statement looks like

( BKPF-BLART = 'SA' OR BKPF-BLART = 'EX' AND

BSEG-HKONT IN ZSPL_VALID_TP )

Does this make sense or this wrong and it should read as

( BKPF-BLART = 'SA' OR 'EX' AND

BSEG-HKONT IN ZSPL_VALID_TP )

Thanks for your help.

Regards,

Noopers

former_member182098
Active Contributor
0 Kudos

Hello,

Both should work.

Make sure that you have assigned the same in OB28.

However, there is no need to click on BKPF-BLART every time, single time would be sufficient and each document document type you segreate with OR as shown below (in your second statement)

( BKPF-BLART = 'SA' OR 'EX' AND

BSEG-HKONT IN ZSPL_VALID_TP )

Regards,

Ravi

Former Member
0 Kudos

Awesome !! Thanks a bunch ! The answers were very helpful

Regards,

Noopers

Former Member
0 Kudos

Hi,

For some reason after I added the additional document we are running into some issues....I am not able to post using FB60, F-53, etc..

The rule before i changed it read as:-

( Document type <> 'SA' AND G/L account IN

ZSPL_VALID_TP ( Accounts requiring Trading Partner )

)

After I made the changes it read as:-

( Document type <> 'SA' OR

Document type <> 'EX' AND G/L account IN

ZSPL_VALID_TP ( Accounts requiring Trading Partner )

)

Did i make a mistake in the way i changed the rule?

Also i have no idea what this ZSPL_VSALID_TP is?

Please can someone help.

Regards,

Noopers

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi,

Locate the validation that you want to change in transaction GGB0, click on the prerequisite you want to edit and then use the menu path Settings -> Expert Mode.

Regards,

Kenneth