cancel
Showing results for 
Search instead for 
Did you mean: 

how do I activate an ICF node in s/4hana cloud

coffeehacker
Employee
Employee
0 Kudos

I am trying to expose a CDS view (I_ProductCostEstimateItemDEX) as an OData service. I have created a custom CDS view that references I_ProductCostEstimateItemDEX, published it, created a communication scenario, added the the custom CDS view as an inbound service to the scenario, and then checked the scenario. I get an error stating that
"ICF node YY1_PRODUCTCOSTESTIMATE_CDS_0001 is not active or initial"

I have no access to the SICF transaction; how do I ensure that it is activated?

amontella96
Active Contributor
0 Kudos

Hi james.tarver , not great input but.. its still a comment after all. i think ur doing something similar to create-cds-views-in-sap-s4hana-cloud-and-consume-them-as-apis , did you flag the ‘oData’ checkbox? its crazy that there is not more questions like yours, isnt it?

cheers!A

TamasFodor
Advisor
Advisor
0 Kudos

Hi,

We helped you to accept the answer, since there were no updates after 7 days. You can unaccept it anytime if you have further questions.

Kind regards,

Tamas

Accepted Solutions (1)

Accepted Solutions (1)

coffeehacker
Employee
Employee
0 Kudos

So the problem was illusory after all. The OData service had been properly created; the problem arose when I sent on OData request for one of the EntitySets without limiting the number of results returned.

Instead of

https://<my tenant hostname>.s4hana.ondemand.com/sap/opu/odata/sap/<my custom cds>/<my entity set>,

I should have asked for

https://<my tenant hostname>.s4hana.ondemand.com/sap/opu/odata/sap/<my custom cds>/<my entity set>?$top=5 (or 10, or whatever)

Alternatively, I could have used a filter

https://<my tenant hostname>.s4hana.ondemand.com/sap/opu/odata/sap/<my custom cds>/<my entity set>?$filter=<fieldname> eq '<fieldvalue>'


One takeaway: if you can make a connection and get metadata, then any issues getting data are most likely with the phrasing of the particular OData query rather than the OData service itself.

Answers (1)

Answers (1)

Saumitra
Product and Topic Expert
Product and Topic Expert

Hi james.tarver : You dont need to activate the ICF nodes in SAP S/4HANA Cloud, public edition as the communication mechanism is governed by the communication systems. In order to expose a custom CDS view as an API, you need to follow the steps mentioned in the help documentation here - https://help.sap.com/docs/SAP_S4HANA_CLOUD/0f69f8fb28ac4bf48d2b57b9637e81fa/f4dcfd6e14b54177b98d6099....

This also gives a good explanations step by step for you to expose the CDS view using the communication arrangements within the documentation here - https://help.sap.com/docs/SAP_S4HANA_CLOUD/0f69f8fb28ac4bf48d2b57b9637e81fa/bff99f6fd7eb4d5a9bdf271e....

This is the way the communication is established without having to activate the ICF node. Please note that using this option you cannot perform POST operation on this API to write back to the custom CDS view, and READ operation is possible.

Thanks,
Saumi

coffeehacker
Employee
Employee
0 Kudos

Hello Saumitra,

Thanks for the pointer to the documentation. I followed the steps in the documentation, and I was able to get the metadata with the generated OData service, but I do not get data. I just get the mysterious "In the context of Data Services an unknown internal server error occurred". When I try to get the error feed in Eclipse, I get an exception stating that I do not have authorization to read the error feed. Do you have any suggestions for troubleshooting?

Thanks.