cancel
Showing results for 
Search instead for 
Did you mean: 

hiding table fields in custom infotype

madhu_reddy22
Participant
0 Kudos

HI guyz,

i have created a custom infotype which has 2 subtypes . certain fields should not be displayed when we select the subtypes. i have used the code below. the screen contains a table.

MODULE hide_FIELDS OUTPUT.

IF p9555-subty = '1'.

LOOP AT SCREEN.

IF screen-group2 = 'ABC'.

screen-active = 0.

MODIFY SCREEN.

ENDIF.

ENDLOOP.

ENDIF.

IF p9555-subty = '2'.

LOOP AT SCREEN.

IF screen-group2 = 'XYZ'.

screen-active = 0.

MODIFY SCREEN.

ENDIF.

ENDLOOP.

ENDIF.

ENDMODULE. " hide_FIELDS OUTPUT

the fields which are not in the table are not getting displayed as required but the fields in the table still appear on the screen(they are grayed out). i do not want them to appear on the screen. can anyone help me with this. Thanks in advance.

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hi Madhu Reddy , instead of using screen-invisible = '1' , u can try this .

MODULE sereen_modify OUTPUT.

DATA: COL TYPE CXTAB_COLUMN.

LOOP AT TC-COLS into COL. " TC is ur Table Control

IF col-screen-group1 EQ '007'. " Modification group1 is say 007.Also u can add other checks like pnnnn-subty = 1 here .

col-invisible = '1'.

col-screen-output = '0'.

modify TC-COLS from COL index COL-INDEX.

ENDIF.

ENDLOOP.

ENDMODULE. " Call this module in ur Flow Loic PBO.

*Reward Points If Helpful

Former Member
0 Kudos

Hi,

Please check following screen values:

ACTIVE  INPUT  OUTPUT    INVISIBLE   
    1       0        1             1
	
Effect: Screen field inactive.
Screen field is not displayed, regardless of the static attributes.

Or 

  0         0        0             1
	
Effect: Screen field inactive.
Screen field is not displayed, regardless of the static attributes.

Regards

Bernd

madhu_reddy22
Participant
0 Kudos

HI Guyz,

i have tried all of those. its not working . the problem is it is working well for all the fields outside the table. but the fields in the table are just getting grayed out. i dont want them to appear on the screen. please help me. i have tried many options. i am sure it has something to do with the table. do i have any options such as screen-delete.

Former Member
0 Kudos

Hello

madhu in debug check wether it is going inside the if condition

may you are checking wrong group number.

if still not getting where problem is then try with screen-name

with all names in OR condition and then screen-invisible = '1'.

reward if helpful

Former Member
0 Kudos

Hi Madhu,

Check whether screen structure is getting modified correctly during run time.

Regards,

Darshan Mulmule

Former Member
0 Kudos

Hi Madhu,

Try Screen-invisible = 1.

Reward if useful.

Regards,

Darshan Mulmule

madhu_reddy22
Participant
0 Kudos

HI Drashan, i have tried it . it doesnt work.is there any other solution.