cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions (0)

Answers (2)

Answers (2)

Sandra_Rossi
Active Contributor
0 Kudos

Did you ever see a screen without a title?

As you can see in your case, if the title is empty, it's automatically replaced with "SAP".

Anyway, if you want to cheat the SAP User Experience, make the title not empty but displaying an invisible character (e.g. here a non-breaking space U+00A0):

sy-title = cl_abap_conv_in_ce=>uccp( '00A0' ).

Out of curiosity, why do you want to hide the title in this screen, while all other SAP screens display one?

Full code for screen above:

REPORT.
SELECTION-SCREEN BEGIN OF BLOCK b01 WITH FRAME TITLE text_b01.
DATA lv_kunnr TYPE kna1-kunnr.
SELECT-OPTIONS so_kunnr FOR lv_kunnr.
SELECTION-SCREEN END OF BLOCK b01.

INITIALIZATION.
  sy-title = cl_abap_conv_in_ce=>uccp( '00A0' ).
  text_b01 = 'ENTER CUSTOMER NUMBER'.
Junaidshaik284
Participant
0 Kudos

Not working

Sandra_Rossi
Active Contributor
0 Kudos

Sorry that it doesn't work in your system. I have updated my answer to show you that it works in mine.

TarunTakshak
Participant
0 Kudos

Hi juneed,

Try below syntax

REPORT <Report-Name>
NO STANDARD PAGE HEADING.

Thanks

Tarun

Junaidshaik284
Participant
0 Kudos

not working and it is showing same same in title bar sap only showing