cancel
Showing results for 
Search instead for 
Did you mean: 

Final Issue Indicator is not set automatically

Former Member
0 Kudos

Hi Experts,

Final Issue Indicator is not getting set automatically for some material in CO02 T.code in component overview, after issue the material 100% against the production order.

I am unable to analysis why it is not getting set automatically, please help me how resolve the issue.

Thanks

Sundeep

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Dear Vempati,

If you are using Production Scheduling Profile for your production order then for the same in OPKP transaction check whether "Confirm Available Partial Qty" indicator is checked? if yes then unchecked it. Now test and confirm.

Regards,

Naresh

Former Member
0 Kudos

Hi Patil,

I am not using production Scheduling Profile for any production order.

Thanks

V.Sundeep

Former Member
0 Kudos

Hi Experts,

Any solution for above issue. i am waiting for the reply.

Thanks

V.Sundeep

muthusamy_sankaran
Active Contributor
0 Kudos

Dear,

Please check the following

1.Goto SAP T-code  OPK4 -Define Confirmation parameters - with Order Type and plant-Goto General valid settings -Maintain Parial Confirmation  and the un-check box for  the post open reservation .If you mark this box , then FI indicaor will be st automatically at Production Order Final Confirmation .

2.Also chekc in Co11n , if ytou do not mark Clear Open Reservation option , then FI indicator will not be set in MIGO or any material posting .

3.In OPK0 , define confirmaiton screen -select SAP001- Hit  in dfault area , if you mark this , then in co11n screen it will come automatically .So flag off the same in OPK0

Hope this helps

Caetano
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello

I have analyzed this issue internally and I have discussed with the PP-SFC developers.

They have confirmed that your system is working as designed and that the final issue indicator is not proposed on transaction CO27.

You can analyze yourself in debug, setting a break-point on program PPIOB000 and checking that tmp_comp_tab-endkz will be always empty.

My suggestion to you is to set the final issue indicator in an implementation of BAdI WORKORDER_GOODSMVT, method PICKLIST. Here, you can implement your own logic to set the final issue indicator.

This will give you the full control over the final issue indicator.

BR

Caetano

muthusamy_sankaran
Active Contributor
0 Kudos

Thanks Caetano.

Caetano
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello

If the system behavior has been explained, could you please close the thread by selecting the correct answer?

BR

Caetano

Former Member
0 Kudos

Dear Caetano,

Thanks for your inputs, for debugging this issue i am unable to create test case in DEV server bcoz i am unable analysis at which scenario the final issue indicator is not get ticked automatically after issuing the components 100% against the production order via co27 t.code.

Please guide how to solve this issue.

Thanks

Sundeep

Caetano
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Sundeep

You should use the suggested BAdI to set the final issue indicator on CO27. As I pointed previously, it is not set automatically on CO27 on the standard system.

BR

Caetano

Former Member
0 Kudos

Hi all,

i have the exact opposite issue,

when confirming partially an operation of production order via BAPI

  BAPI_PRODORDCONF_CREATE_TT, the final issue indicator is set for backflushed materials with COGI or which are not totally delivered ..

have you already experienced the same issue?

Thanks,

regards

Former Member
0 Kudos

Hi Experts,

Can any one give the solution for resolving the issue. still i did not the implement the above two note.

Thanks

V.Sundeep 

Former Member
0 Kudos

Hi,

Please check the following,

1.Goto SAP T-code  OPK4 -Define Confirmation parameters - with Order Type and plant-Goto General valid settings -Maintain Partial Confirmation  and the un-check box for  the post open reservation .If you mark this box , then FI indicaor will be st automatically at Production Order Final Confirmation .

2.Also check in Co11n , if you do not mark Clear Open Reservation option , then FI indicator will not be set in CO02.

3.In OPK0 , define confirmation screen -select SAP001- Hit  in default area , if you mark this , then in co11n screen it will come automatically .So flag off the same in OPK0.

Thanks,

Naresh

Former Member
0 Kudos

Hi Patil,

Thanks for your Reply...

I know above solution provided by you but i want to get set final issue indicator automatically when i complete 100% issue the component through co27 tcode. I am unable to find the reason why some components are not getting set automatically.

Thanks

v.sundeep

Caetano
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Sundeep

How are you posting this goods issue? Did you check if the withdrawal quantity was updated?

If you don't post the goods issue with reference to the reservation, it will be considered an unplanned goods movement. In this case, the withdrawal quantity is not updated and the final issue indicator is not set.

BR

Caetano

Former Member
0 Kudos

Hi Casetano,

I am posting goods issue through CO27 T.Code and withdrawal quantity was updated.

I am unable to analysis why it is not getting set automatically, please help me how resolve the issue. 

Thanks

Sundeep

Caetano
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello Sundeep

How often this is happening? Does it happen for all the components of all orders or is it happening under specific circumstances?

If it happened only for this specific order, it may be a one-time inconsistency and you should set it directly on the order.

If you are using AFS, note 1682261 may be relevant.

BR

Caetano

Former Member
0 Kudos

Hi Caetano,

It is happening in very rare cases not for all orders. In a order one or two components Final Issue Indicator is not getting set automatically. For Example if i am doing 200 production orders picking at once by using co27 t.code, 10 production orders that too one or two components in each order the Final Issue Indicator is not getting set automatically.

Thanks

V.Sundeep

sjeevan
Active Contributor
0 Kudos

Check if this is happening with components under phantom assemblies, if yes implement this note 1624944

Former Member
0 Kudos

Hi Jeevan,

Those components are not under Phantom assemblies and please confirm if i apply this note 1682261 the error will resolve or not.

Thanks

V.Sundeep.

Former Member
0 Kudos

Hi Caetano,

Can i know the full form of AFS, as per assumption it is After Final Issue Set if i am wrong please correct me.

Thanks

V.Sundeep

sjeevan
Active Contributor
0 Kudos

I'm not sure if that note will resolve it but you can implement the note and check.

Anyway, I'm thinking that you may have rounding problem with unit of issue of those components different than base unit of measure, something like in the below thread.

http://scn.sap.com/thread/3237996

Also, AFS = Apparel and Footwear Solution,

it's an industry specific ERP solution by SAP for Apparel and footwear industry.

You can read an introduction about it here,

AFS SCN Wiki

and more here

AFS SAP Help

Former Member
0 Kudos

Hi Jeevan,

I am not having problem in rounding value, it is working fine.

Thanks

V.Sundeep