cancel
Showing results for 
Search instead for 
Did you mean: 

FI-SL: Direct posting => Error message no. GI191

Former Member
0 Kudos
803

Hi all,

I'm trying to post directly in FI-SL with the transaction GB01. Unfortunately, I receive the message n°GI191 indicating that "Line item 100000001 000001 is not posted to any FI-SL ledger".

In the message, the procedure to correct that is:

- Check the assignment of the ledgers to the activity/company code or activity/global company.(Customizing Ledgers

)

OR

- This error message only appears if the activity is so defined that each document line has to be posted to FI-SL.(Customizing Activities)

I checked the customizing but all seems correct:

- With GCL2, I linked the SL ledger and the operation; and the operation with the transfer zone

- in GCP1, th local postnigs periods are well customized

- in GB04, number ranges intervals are customized for my company

- in GCBX, A0 is indicated as a valid document type

..

Could you please help me to solve this problem? Thank you very much in advance!!

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi

Pls go through the Note 125002 - GB01: GI191 if only additional currency entered

Here either no ledger is assigned which manages the additional currency entered (as detailed in the long text of the error message ) - in which case the error message is right - or you have posted in an additional currency which matches the local currency

verify above it will solve your issue

Reg

Vishnu

Former Member
0 Kudos

Thank you Vishnu. Is it possible for you to send me the note 125002?

Former Member
0 Kudos

HI

Symptom

For an FI-SL direct posting the error message GI191: 'Line item & & is not posted into the FI-SL' is generated if you use a document type which only manages additional currency (3rd currency).

Additional key words

GB01, GB11

Cause and prerequisites

Prerequisite: either no ledger is assigned which manages the additional currency entered (as detailed in the long text of the error message ) - in which case the error message is right - or you have posted in an additional currency which matches the local currency. The error message is then incorrect and a program error exists.

Solution

Insert the advance corrections in the source code as set out in the attachment.

But i cant attach here the correction, you need to download the correction in sap market place or try it in google

Reg

Vishnu

Former Member
0 Kudos

Hi, this note relevent up to release 45A, and which release you are?

Check cimbination Ledger/Company code/Activity - if Write items is specified

Former Member
0 Kudos

I am in SAP ECC 6.0.

In GCL2, "Write Line items" is specified.

The ledger ("Z2") is well linked with the company ("GB60"). The combinaison Ledger/Company code/activity seems OK...:(

Former Member
0 Kudos

Hi, so write items set for Ledger as well as for Ledger/Company code/ activity(RGL0)?

Former Member
0 Kudos

Yeah, in the customizing, we are using the activity RGL0: we just modified to allow "Write line items". (GCV2)

Below, what I exactly did:

1/ GCV2: activity RGL0 -> just allow "Write line items"

2/ GCF1: Create field movement "ZSLD", copy of "ZSUE"

3/ GCL2: Add RGL0 for our ledger "Z2" and affect the activity "RGL0" with the field movement "ZSLD"

4/ GCP1: enter Local posting periods for our company "GB60"

5/ GB04: for company code "GB60", indicate number range intervals

6/ GCBX: for document type "A0", tick the columns "TC", "C2", "C3", "No balance check", "Local" "Global"

Former Member
0 Kudos

While posting are you put Target ledger?

Also compare customizing for currencies for ledger and Doc.type

Former Member
0 Kudos

When I post in GB01, I choose "Specify target ledger" and then, indicate my ledger "Z2".

For the currencies, I'm not sure if it is what you want to know but these are the checks I did:

- GCL2 (for the ledger): 1st currency= "Transaction currency"

2nd currency= "Company code currency"

3rd currency: Not yet defined

- GCBX (for the doc type): "TC", "C2" and "C3" are ticked

Former Member
0 Kudos

Hi, try to untick 3d currency for doc. type

Former Member
0 Kudos

It does not work neither but thx for your help... I gonna try to start the customizing from the beginning....:(

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi, you need to make customizing Write line item in GCL2 at reuired level

Former Member
0 Kudos

Thank you Aleksey but I checked and "Write line item" is already ticked.

For AD, thx too but the ledger is assigned to the operation/company.

Former Member
0 Kudos

hi

please check the assignment of the ledgers to the activity/company code or activity/global company.