cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR: Search connector for category EAM_TECHOBJ is not active

vineeth_varghese
Active Participant
0 Kudos

Hi,

If we search for Equipment number during the create Notification (IW21) screen from SAP NWBC (web UI), we are getting the below mentioned error.

"Error: Search Connector for category EAM_TECHOBJ is not active"

The customization "Activate enterprise search for input help" is active and details can be seen in attached screenshot. Also checked customizing maintenance view (table)- V_EAMS_ESH_CAT and it is fine.

I need some help to understand this error if  anyone faced similar situation.

Please refer attachment.

Vineeth

Accepted Solutions (0)

Answers (2)

Answers (2)

melanie_kleber2
Advisor
Advisor
0 Kudos

Hello Vineeth,

I answered your post about this topic in the Web Dynpro Area before I've seen this one here. From your screen shots I can see, that you have the correct EAMS connectors running. Add category EAM_TECHOBJ in connectors EAMS_EQUI and EAMS_BUS0010. I assume that the system has a lower support package than SP11. This category assignment in the cockpit is not transportable - you have to do it in all your systems. For further clarification see my note 2274409.

The search category EAM_OBJECTS from the PFCG role is only relevant for the EAM Master Data Info Center. This is a category which combines several connectors (via their categories) to search in by typing a free text, for example, in the search UIBB of the Info Center.

Best regards,

Melanie Kleber

MTerence
Active Contributor
0 Kudos
vineeth_varghese
Active Participant
0 Kudos

Thank you Maria, I will check this and come back to you.

Vineeth

vineeth_varghese
Active Participant
0 Kudos

Hi,

Based on the input from Maria Terence, I could check the relevant customization data and still need some more help. I understand that the EAM* search connector is now active, but whether we should assign the search category to connector in ESH_COCKPIT. I took screenshot and attaching it here. If someone could guide me further, it would be very helpful. I refered to S Note- 2274409, but its about creating category and assigning it to Role. Eventhough the S Note and responses was very helpful, My error hint that search connector for a particular category is not active. Kindly refer my attachment in this reply.

Vineeth

MTerence
Active Contributor
0 Kudos

Hi Vineeth,

I dont think you will get much information about this here, you can input the Equipment category and check whether it works.

Also check with Technical forum, so confirm your issue or raise to SAP

Regards

Terence

Former Member
0 Kudos

HI Vineeth,

I am not sure but could you please check whether below views has correct entries.

V_EAMS_UI_SHLP

V_EAMSC_UI_SHLP

Regards,

Amol

Former Member
0 Kudos

HI Vineeth,

Also try to check through this link.

Creating and Activating Search Object Connectors - Utilizing the Help Center for SAP Business Suite ...

Hope this might help you.

Regards,

Amol

vineeth_varghese
Active Participant
0 Kudos

Thanks, I will check both.

Will try to close this post with some kind of hint as I am working on it.

Vineeth