cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Personnel Actions (PA40)

Former Member
0 Kudos
929

Hi Mentors

I'm new to the forum and just started learning SAP HCM

Need your help in running Personnel Actions.

I have setup the Personnel Actions using the following nodes from SPRO:

1. User Group Dependency on Menus and Info Groups- Menu type G

2. Info group modifier - IGMOD feature

3. Define Infogroups

4. Set up Personnel Actions

5. Create Reasons for Personnel Actions

6. User Group Dependency on Menus and Info Groups- Menu type M

7. Change Action Menu

Also, I have setup Internal Number Ranges and maintained NUMKR feature.

ERROR:

When I run the Personnel Actions (PA40) the system is not assigning the personnel number in IT0000. After saving this infotype, it moves to 'Create Actions' screen. Here the status bar displays the error as u201CNo infotype found. Maintain infogroup modifier/ user groupu201D

Please guide.

Thanks

Bala

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

The user group and country groupings in Tcode SU3 under parameter Tab should be the same as your UGR settings and MOL Settings,kindly confirm this and then check whether your actions are seen in PA40 as configured by you.

Salil

Former Member
0 Kudos

Hi Salil

Thanks for the inputs.

I have already maintained same parameter value '40' for UGR and MOL settings.

And the user group dependency on Menu G and Menu M are also maintained with same value '40'

But the error still exists.

Please help.

Regards

Bala

Former Member
0 Kudos

Hi,

Check Table T77S0,NUMRG is activated or not.

Salil

former_member148407
Active Participant
0 Kudos

Hi,

Pls check that in your last step "Change Action Menu", you have to give "01" in the menu and then assign your action to the user group.

Just try with this and hopefully it will solve your problem.

Thanks

Ranjeeta

Former Member
0 Kudos

Hi Salil

NUMRG was not activated in tabel T77S0. I have marked 'x' to activate it.

But I still get the same error.

Bala

Former Member
0 Kudos

Hi Ranjeeta

I have already given the value '01' in Change Action Menu and assigned the Action type to the user group '40' (similar to the UGR and MOL settings).

The error still remains.

Regards

Bala

Former Member
0 Kudos

Hi,

Please do some changes like :- SU3 UGR 00 and User Group Dependency on Menus and Info Groups-- Ref=01 and in Info group user group 01and User Group Dependency on Menus and Info Groups ---00 and in action menu under 01 user group 00 and your action type.

Change like this and share the result.

Regards,

ARU

Former Member
0 Kudos

Bala,

Check the following as well -

1. if you have put any dependency on reference group as well.

2. Whether you have assigned correct info group in T529A.

Also, let us know the error message number which you can get by double clicking on message.

Former Member
0 Kudos

Hi Praveen

I'm unable to understand your 1st question. Could you please give me some more clarity.

For the 2nd question, I have checked table T529A and the infogroup is correctly given.

And the error number is PG011

Regards

Bala

Former Member
0 Kudos

Hi ARU

I tried with your suggestion. But still the error exists.

Regards

Bala

Former Member
0 Kudos

Hi Bala,

Are you maintianing UGR parameter in your user profile,if not please try that.

Thanks,

Sheshu

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi,

This error message PG 011 "No infotypes found. Maintain infogroup 

modifier/user group" is trigerred as there is missing customizing in your system. 

Every Personnel Action must be assigned an infogroup must be assigned to every personnel action. This takes place in table T529A (Personnel Action Types). 

Also check in table V_T588S (Infogroups) that there is an entry for your infogroup. 

This entry is maintained via customizing (tcode SPRO), here is the full access path 

> IMG --> Personnel Management --> Personnel Administration --> Customizing Procedures --> Actions -- > Define Infogroups -->INFOGROUP 

Also check that the reference Infogroup (in standard '01') is maintainted and the your user master record contains the UGR parameter, if not reference Infogroup is maintained in the customizing. 

Regards,

ARU

Former Member
0 Kudos

Hi,

For what you want to configure IGMOD feature any specific condition you want to apply or waht?

Regards,

ARU

Former Member
0 Kudos

Hi Aru,

Please check the operations of the infotypes.

2. Check whether you have assigned the infotype modifier in infogroup.

3. Check the user groups.

Regards,

Kamala

Former Member
0 Kudos

Hi,

Thanks but this issue is not posted by me. The owner is BALA.

Regards,

ARU

Former Member
0 Kudos

hi,

for your information

menu type M should be 1(Actions) or any thing that you have defined.

here you will give

UGR seq.no action type action text

xx 21 M1 Hiring

xx 22 M2 xxxx

xx 23 M3 xxxxx

xx 24 M4 xxxx

menu type G is Info group

menu type M is Personnel action menu

menu type G you will group the infotypes and make the infogroup. and this infogroup is inserted into menu type M(personnel actions menu)

what ever the user group you have used in menu type M it should be at parameters in T.code : SU3

and the MOLGA is country grouping. you have to input the MOLGA for which country you are doing this actions.

because country country the infotype screen are different.

hope this will help you,

regards,

mohammed

Former Member
0 Kudos

Hi Mohammed

Thanks for inputs. I have already made the same configurations that you have mentioned.

Regards

Bala