cancel
Showing results for 
Search instead for 
Did you mean: 

DI Server login fault

Former Member
0 Kudos
210

Hello.

I've had an ASP.NET service running for months. This service call a DI Server method.

Recently we upgraded to SBO 2007 (also DI Server) and I'm now unable to login to DI Server.

  • DI Service upgraded

  • ASP.NET Service upgraded with new 2007 library.

Log:

18/11/2008 15:05:41 Response (Fault)

<?xml version="1.0"?><env:Envelope xmlns:env="http://www.w3.org/2003/05/soap-envelope"><env:Body><env:Fault><env:Code><env:Value>env:Receiver</env:Value><env:Subcode><env:Value>-1</env:Value></env:Subcode></env:Code><env:Detail><Command>Login</Command></env:Detail></env:Fault></env:Body></env:Envelope>

Can't find any information on the -1 error.

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

I haven't used B1WS, since it doesn't work for me. I can only suggest actions using the DI server directly.

- Have you updated the reference to B1DI_Server.exe in your original project as well? I guess it used to reference the 2005 version of the DI server, so you have to update that as well.

- Have you tried connecting to the sample webservice in the SDK directory? Invoke the webservice and fill in the details. Which response do you get? Mine is here: C:\Program Files\SAP\SAP Business One SDK\Samples\DI Server\CSharp\DIServerBP\DISSample

Former Member
0 Kudos

I've now tried the B1WS service.

Running the WSDLGenerator i'm getting the same error.

Former Member
0 Kudos

It probably won't help, but you can always try this:

<LicenseServerName>np-fs02</LicenseServerName>

<LicenseServerPort>30000</LicenseServerPort>

in stead of this:

<LicenseServer>np-fs02:30000</LicenseServer>

Former Member
0 Kudos

Both database and license server properties point to server name. Just restarted the server.

18/11/2008 15:47:37 Request

<?xml version="1.0" encoding="utf-16"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><dis:Login xmlns:dis="http://www.sap.com/SBO/DIS"><DatabaseServer>np-fs02</DatabaseServer><DatabaseName>NP_Prod</DatabaseName><DatabaseType>dst_MSSQL2005</DatabaseType><DatabaseUsername>username</DatabaseUsername><DatabasePassword>password</DatabasePassword><CompanyUsername>username</CompanyUsername><CompanyPassword>password</CompanyPassword><Language>ln_English</Language><LicenseServer>np-fs02:30000</LicenseServer></dis:Login></soap:Body></soap:Envelope>

Former Member
0 Kudos

It's the dreaded 'General Error'.

Check the license server. Does it point to 'localhost' or the server name? Make sure it points to the server name, even if it is localhost.

Rebooting both server and client PC might make a difference.

Good luck.