cancel
Showing results for 
Search instead for 
Did you mean: 

Changing time evaluation period

Ivaneee
Participant
0 Kudos

Hi masters,

I´m following this post: http://scn.sap.com/message/14195529

to change my time evaluation period from 26th to 25th next month.

time schema is ok, the balances are calculate ok, but in pt_Bal00, it´s showing the balances from previous month.

My employee is active from 1st of March but time evaluation is calculated from 1st of April (to 25th of the same month)

I re-generate RPTIME00, SAPFP51T, RPTEDT00 and RPTBAL00, but for example if I have a balance of delay calculated for day 4 and April 5, and the report pt_bal00 is showing me for the 7 to March 8.



I deleted the cluster B2, recalculated times and relaunched the pt_bal00 and the same.

internally, I see that 1st of April, in ZES is 7th day (logically, because first day of time evaluation is 26th of March)

Any idea? thanks a lot.

Accepted Solutions (1)

Accepted Solutions (1)

Ivaneee
Participant
0 Kudos

If I put again DATA RPTIME_PERIOD(2) VALUE '01' and throw again PT60, PT_BAL00 is showing correctly the balance that i´m looking for:

former_member193652
Active Contributor
0 Kudos

Dear van,

Please let me know which period you have defined as 26th to 25th? Please share screen shot of definition of this period(let me call time period) from V_T549R and V_T549Q.

Regards,

Omid

Ivaneee
Participant
0 Kudos

Hi Omid! sorry for not answering earlier, I was on holiday yesterday.

there is my V_T549R:

and V_T549Q:

and TRMAC:


former_member193652
Active Contributor
0 Kudos

Dear Ivam,

Everything seems correct! I have some recommendation:

- Hire an employee and run time evaluation for it to make sure there is no data in clusters. Buy the way don't forget to regenerate PT66 to see the cluster data.

- If you have another system like an IDES try to check out it on another system.

- Try to find what's going wrong thru DEBUG

I am sure it's a small issue and you can solve easily. If I had access to system I would have a look at it.

Regards,

Omid

Ivaneee
Participant
0 Kudos

'll keep looking to see if I encounter the solution!

thanks a lot Omid, if I find the solution I'll write

Regards!!

Ivaneee
Participant
0 Kudos

regenerating PT66 again, the problem was solved!!! thanks a lot Omid!!!

Former Member
0 Kudos

Hi, I have a situation similar to above. Time evaluation has to be generated for Bi-weekly & semi-monthly group, changed the Macro on ABKRS for '02' for Semi monthly and '04' for Bi-weekly. Successfully generated RPTIME00 & RPTBAL00. Time driver is getting executed successfully based on ABKRS,  but PT66 is not showing according to the period. Tried to generate PT66 getting an error as it does not have ABKRS in selection. Any inputs/ suggestions?

Thanks

Karthick

former_member193652
Active Contributor
0 Kudos

Hi Kar,

Yes you must regenerate PT66(Program RPCLSTB2) to have correct result. What you say is a strange case!

I recommend sharing screenshot of what have you changed and error message to have a look.

Regards,

Omid

Former Member
0 Kudos

Please find the screenshot attached.

Code for Macro. Payroll area U1, U2 are semi monthly and U3 is Bi-weekly.

While generating RPCLSTB2 facing the below error, note: LDB is not used in this report.

former_member193652
Active Contributor
0 Kudos

Hi Kar,

I see you have changed the concept of time period by adding some codes into in. It does not make sense to change PT period based on payroll area. If this is the case you should find another solution.

Regards,

Omid

Former Member
0 Kudos

Hmmm ...Omid, I have reverted back the changes coded based on payroll area as I could not find a solution for PT66. Currently our Macro is set to 02 which is as is.

As mentioned earlier I had to generate accrual based on payroll period for Biweekly & semi-monthly. As the time eval period is set to Semi-monthly, the Bi-weekly accrual is not getting accrued perfectly. for e.g. the biweekly accrual should multiply with no. of hrs worked x constant (.0234). if my 1st period for Biweekly ends on 1/14 and 2nd period starts from 1/15 as per payroll period, 15th the hours are getting initialized because time eval start from 16th (semi-monthly). How can I make sure the hours from 15th are getting calculated? if I try time type transfer from previous period it is transferring the whole period hours...

Any inputs/suggestions.

former_member193652
Active Contributor
0 Kudos

Which kind of accrual you mean? If you look for quota generation you can do it by V_T559L.

Answers (1)

Answers (1)

former_member193652
Active Contributor
0 Kudos

Hi Ivan,

Based on my document at http://scn.sap.com/docs/DOC-45887 and SAP Note 555588 which has introduced by Woddy there I think everything should be ok if you have regenerated the RPTBAL00.

I recommend to run this report and check your time type day to day. As you you said your first day must be the same as 26th, March in ZES.

By the way are you making your report from 26th March to 25 April? Please share a screen of your selection screen of PT_BAL00.

Regards,

Omid

Ivaneee
Participant
0 Kudos

Hi Omid,

Here you are, a screen of my PT_BAL00 selection:

As you can see, the data range is ok but isn´t showing my 9903 balance, and the employee is calculate from 1st of April to 30th of April too. in infotype 0003, CDP retroactivity is waiting to 1st of May. everything is ok.

But if i change these data:

is showing these balances but in another day.

as I've said, I've generated the PT_BAL00, and the evaluation of time balances out the days I play:


former_member193652
Active Contributor
0 Kudos

Hi Ivan,

As I see the time type value is 0.18 and it seems correct in daily base. You know ZES also keeps the daily values. If you would see the monthly value check SALDO and in PT_BAL00 select the second option.

Cheers,

Omid

former_member193652
Active Contributor
0 Kudos

I got the date issue. Are you running time evaluation successfully and it finish end of period?

Go into PT66 and double click here to see which date is here

And I recommend to run it for fresh EE to see the result. Maybe you need to delete all data in clusert B2 then run PT60.

Regards,

Omid

Ivaneee
Participant
0 Kudos

yes, it finish correctly, in 25th of the month. and EOM is correct under 25th.

take a look:

i delete B2 cluster with RPUP2D00 and doesn´t correct my problem...

Ivaneee
Participant
0 Kudos

sorry, and this is BEZUG from my period: