Showing results for 
Search instead for 
Did you mean: 

Change Number Mandatory for Routings not working

Former Member
0 Kudos


I have done the required customization for field selection task in Routing customization.

Actually My requirement is to make "Change number mandatory for a specific plant" while changing the routings

Now to achive this I have done the following settings

1. Place the cursor on a screen group. ( Selected the PP Task list Overview screen)

2. Choose the function key Modifiable.(Selected the Change Number Field)

All of the fields which you can modify for this screen group appear on the screen.

3. Double-click on a modifiable field for which you want to maintain influencing values.

All of the influencing fields appear on the screen.(Selected and double click the "Change Number Field)4. Place the cursor on an influencing field for which you would like to enter a value and select New Values. ( Selected Plant Field and clicked on enw values)You see a dialog box.

5. Maintain the value and indicators for the influencing field, and choose Continue.

The values are accepted.(Mainatained the Plant Code so that Change number will be maindatory only for this plant)

6. Saved entries.

First time on Ca02-> But i am getting the strange results as When I got to CA02 and enter the plant and material number , its allowing first time without asking change number

Second time on CA02 --> Then I come out and on initial screen I can see the change number mandatory even for the other plants , however I maintained influencing firld value only for one plant .

Can you pl lep me in this as its became now very critical for me , i have tried all my tricks , but its not going for me at the moment

Is there any other setting for this which I am missing ?

Thanks to all in advance

View Entire Topic
Former Member
0 Kudos


You can check the transaction OS54 settings and go to CC01 & CC02

In this CC01, Change no status is active then click on Object types button and then you can check for description 'Routing (Task list)' and Active status is ticked.

If you maintained these above settings, when you created or changed for Routing, system should ask manadatorily for change no for particular plant.

so the change no status is active, In case if you don't want to maintain change no, you can maintain the status 'Inactive'.

Please let me know any clarifications.