cancel
Showing results for 
Search instead for 
Did you mean: 

Auto Open Excel

Former Member
0 Kudos

Hi,

We've experienced something everytime we try to save a document in excel through the system, it opens an excel sheet (which is used by another user). I tried solving when I moved autopen.xls located in Exceldocs folder to another place, without success.

What can I do to avoid Excel to open when saving .xls documents in system?

 

Thank you very much for your help.

Regards.

Accepted Solutions (0)

Answers (5)

Answers (5)

0 Kudos

Hello Maria,

Are you creating excel file through SAP Addon (SAP SDK)?
If yes, you have to set Visible property to False.

For example (VB.Net):


Dim objXlApp As Excel.Application = New Excel.Application
Dim objWB As Excel.Workbook
''your code goes here
objXlApp.Visible = False

''your code goes here



Please close your thread by marking helpful/correct answer.


Thanks,

Ashish

KennedyT21
Active Contributor
0 Kudos

Please close your thread by marking helpful/correct answer.

Thanks,

Kennedy

Former Member
0 Kudos

Hi,

Your requirement is different with majority of others. Most complains here are Excel cannot be opened.

An easy way is to search the related threads on the forum to know what its original problem is so that to imitate Excel will not be opened.

Thanks,

Gordon

KennedyT21
Active Contributor
0 Kudos

Hi Maria,

i think due to macro security set to low or trusted document.

just open the workbook, hit alt + f11 and on the side bar there will be a part that says Modules or Forms.  right click the module or form and hit Remove.  say no you dont wanna save it.

Regards

Kennedy

Former Member
0 Kudos

Hi,

Thanks for your replies,

We set Macro Security to high and not trust the publisher, but it's still opening up Excel at the time I try to save a document (eg. a query ) to excel in Sap Business One. I also tried holding down shift key at opening the file that Macro (AutoOpen), but it didn't work.

This thing it's happening since Ms Office was installed on the server. We haven't been able to solve it since then...

Any ideas?

Regards.

KennedyT21
Active Contributor
0 Kudos

HI Maria,

For export option activate On SAP B1 client machine you have go general setting > Go to path > than provide SAP sever Excel Doc Path.

and  please confirm in that folder Auto open.xls file is there or not.

and than go to new excel file > Excel Option -->Trust center -->Disable all macros without Notification

Than try to open excel file.

May it help you.

If its not work so you check on sever if its working on sever than if definitely client machine problem.

for that you have re-installed SAP client.

Regards

Kennedy

Former Member
0 Kudos

Hi Maria........

Please check this link and do the recommended settings.

This may solve your issue........

http://www.jkp-ads.com/articles/preventopenevent.asp

Regards,

Rahul