cancel
Showing results for 
Search instead for 
Did you mean: 

AB4 - The new ABAP editor

Former Member
0 Kudos

Hi to all

I guess you all have read <a href="https://www.sdn.sap.comhttp://www.sdn.sap.comhttp://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/uuid/92a04d07-0501-0010-1f99-9c7ee0e3fab1">about AB4 (the new ABAP editor).</a> It says it will be available from SAP GUI release 7.0 .

So, does anyone know when the 7.0 version is planned to be released?

Regards

*--Serdar <a href="https://www.sdn.sap.com:443http://www.sdn.sap.comhttp://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.sdn.businesscard.sdnbusinesscard?u=qbk%2bsag%2bjiw%3d">[ BC ]</a>

Accepted Solutions (1)

Accepted Solutions (1)

alexey_arseniev
Advisor
Advisor
0 Kudos

Hi Serdar,

yes it will be included in SAP GUI 7.0 and even into SAP GUI 6.40 Patch 10.

BUT: to have the editor integrated into ABAP Workbench and all transaction other related transactions (SE38, SE24 etc) you need to have also support of the backend. And the first backend version supporting AB4 Editor is Basis 7.0 (SAP_BASIS 700, WAS 7.0). Unfortunately.

Some more details you can get also in Weblog from Bjoern Mielenhausen https://www.sdn.sap.com/sdn/weblogs.sdn?blog=/pub/wlg/1565. [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken]

Best regards,

Alexey.

Message was edited by: Alexey Arseniev

NataliaGlants
Explorer
0 Kudos

Hi Alexey.

It hears GREATE!!

Where can I download "The new ABAP editor" from?

Thanks, Natalia.

vladimir_golovtchiner
Participant
0 Kudos

Hello Alexey!

In PDF-Document stood that "The AB4 Editor interface is optimized to work with the SAP Frontend for W32 compatible platform versions 4.6c and higher... fully integrated in SAP R/3 environment...."

What does it mean? So far as i know the last version of SAP R/3 is 4.7 - Enterpreis. What are you speaking about if you say "first from 7.0 " Is it the version of WAS?

Many thanks

Vladimir

alexey_arseniev
Advisor
Advisor
0 Kudos

Hi Vladimir,

here is a link

I have answered this question already to Frank, and don't want to create redundant information

Best regards,

Alexey.

alexey_arseniev
Advisor
Advisor
0 Kudos

Hello Natalia,

you should download it together with WAS 7.0 and SAP GUI 6.40 Patch 10 or higher

The editor comes together with SAP GUI 6.40 Patch 10 or higher installation but you can switch to it in ABAP Workbench only if you have SAP_BASIS component version 700 or higher.

Best regards,

Alexey.

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi all,

I think it would be better just to have only one discucssion about this topic.

Is anyone able to "merge"

of the ABAP programming forum and

of the SAPGUI forum

regards

jürgen

ssimsekler
Active Contributor
0 Kudos

Hi to all

Thank you Alexey for the info. It made things clearer. And sorry for being late for this verbal thanks.

Jürgen, in the post at the SAP GUI Forum, I've stated that the issue was also posted in this forum. And with your request, I made the noticement as a link to this thread. I hope that will make it some easier to follow.

*-- Serdar

RichHeilman
Developer Advocate
Developer Advocate
0 Kudos

Good question. I was guessing that it would be released with netweaver 05 in the fall.

Regards,

Rich Heilman