cancel
Showing results for 
Search instead for 
Did you mean: 

671 ABAP/4 processor: SAP SQL_ARRAY_INSERT_DUPREC

Former Member
0 Kudos

i'm getting this message everytime i try to post something(f-02, vendor/ miro/migo) any type of entry.

can someone please explain this to me? the message is too technicalfor me to comprehend. so i hope the solution isnt that technical..

points will be gratitiously rewarded. thanks

Accepted Solutions (1)

Accepted Solutions (1)

former_member184992
Active Contributor
0 Kudos

Hi,

The most important information it is not present in your thread.

Please provide the information that appears after this part

"The termination occurs at........ in program...... " ???

This will determine exactly which area is responsible for the error message.

Best Regards,

Vanessa.

Former Member
0 Kudos

please help me out in this case.. It is highly appreciated

former_member184992
Active Contributor
0 Kudos

Hi,

This dump has occured for other customers before. It is mainly due to 'wrong' or overlapping number ranges, please check if the last used in the range is the same as stated in customizing at number range interval.

Since you are receiving this error in many different transactions (FI, MM), I would check number range customizing for FI documents, PO, PR and MM invoices. One of them (or more) is the cause of your issue.

Your error definitely is related to number range, but I cant say exactly which one (FI, MM, SD and so on), since you said that you cant see the program/include where this error is issued. Even in ST22 transaction, you cannot see more details about the issue? Or in the inbox (when this dump is sent by email)? Anyway, I would start to check the number ranges customizing, and my feeling is that it is in FI number range, it would be a good start point for checking.

Best Regards,

Vanessa.

Former Member
0 Kudos

hi vanessa, i wasn't aware of ST22 before. i went there and there are definitely more details.

I went to a few of the errors and this is the problem according to the report.

The current ABAP program SAPGLIU had to be terminated because it came across a statement that unfortunately cannot be executed.

Please let me know what more information you need out from that page

Thanks

former_member184992
Active Contributor
0 Kudos

Hi,

We are getting closer

Please run program RGZZGLUX. You should execute report RGZZGLUX to regenerate modules and structures in FI-SL.

This process will take about 5 minutes.

IMPORTANT: In a live system no postings should occur during the regeneration!

Check on note 764523 and 976463 for additional information on this process.

Please, make sure that nobody is posting while you are executing this.

Program RGZZGLUX will not run for a long time and it does not have selection screen.

I believe that this will resolve your issue.

Best Regards,

Vanessa.

former_member184992
Active Contributor
0 Kudos

Hi,

In case your issue persisted, please COPY and PASTE the content of the dump that you found in transaction ST22 inside this thread (at least the first 3 pages).

Best Regards,

Vanessa.

Former Member
0 Kudos

The program ran fine without problems but it didnt fix anything. This is the message you wanted. Do you also want the source code extract?

error analysis

Runtime Errors SAPSQL_ARRAY_INSERT_DUPREC

Exception CX_SY_OPEN_SQL_DB

Date and Time 06.02.2012 20:48:12

Short text

The ABAP/4 Open SQL array insert results in duplicate database records.

What happened?

Error in the ABAP Application Program

The current ABAP program "SAPLGLIU" had to be terminated because it has

come across a statement that unfortunately cannot be executed.

What can you do?

Note down which actions and inputs caused the error.

To process the problem further, contact you SAP system

administrator.

Using Transaction ST22 for ABAP Dump Analysis, you can look

at and manage termination messages, and you can also

keep them for a long time.

Error analysis

An exception occurred that is explained in detail below.

The exception, which is assigned to class 'CX_SY_OPEN_SQL_DB', was not caught

in

procedure "INS_FAGLFLEXA" "(FORM)", nor was it propagated by a RAISING clause.

Since the caller of the procedure could not have anticipated that the

exception would occur, the current program is terminated.

The reason for the exception is:

If you use an ABAP/4 Open SQL array insert to insert a record in

the database and that record already exists with the same key,

this results in a termination.

(With an ABAP/4 Open SQL single record insert in the same error

situation, processing does not terminate, but SY-SUBRC is set to 4.)

How to correct the error

Use an ABAP/4 Open SQL array insert only if you are sure that none of

the records passed already exists in the database.

If the error occures in a non-modified SAP program, you may be able to

find an interim solution in an SAP Note.

If you have access to SAP Notes, carry out a search with the following

keywords:

"SAPSQL_ARRAY_INSERT_DUPREC" "CX_SY_OPEN_SQL_DB"

"SAPLGLIU" or "LGLIUF1A"

"INS_FAGLFLEXA"

If you cannot solve the problem yourself and want to send an error

notification to SAP, include the following information:

1. The description of the current problem (short dump)

To save the description, choose "System->List->Save->Local File

(Unconverted)".

2. Corresponding system log

Display the system log by calling transaction SM21.

Restrict the time interval to 10 minutes before and five minutes

after the short dump. Then choose "System->List->Save->Local File

(Unconverted)".

3. If the problem occurs in a problem of your own or a modified SAP

program: The source code of the program

In the editor, choose "Utilities->More

Utilities->Upload/Download->Download".

4. Details about the conditions under which the error occurred or which

actions and input led to the error.

The exception must either be prevented, caught within proedure

"INS_FAGLFLEXA" "(FORM)", or its possible occurrence must be declared in the

RAISING clause of the procedure.

To prevent the exception, note the following:

System environment

SAP-Release 700

Application server... "gcecc62"

Network address...... "192.168.10.1"

Operating system..... "Windows NT"

Release.............. "5.2"

Hardware type........ "Intel 80686 (Mo"

Character length.... 16 Bits

Pointer length....... 32 Bits

Work process number.. 6

Shortdump setting.... "full"

Database server... "GCECC62"

Database type..... "ORACLE"

Database name..... "ECC"

Database user ID.. "SAPSR3"

Char.set.... "C"

SAP kernel....... 700

created (date)... "Aug 29 2006 00:18:21"

create on........ "NT 5.0 2195 Service Pack 4 x86 MS VC++ 13.10"

Database version. "OCI_10201_SHARE (10.2.0.1.0) "

Patch level. 75

Patch text.. " "

Database............. "ORACLE 9.2.0.., ORACLE 10.1.0.., ORACLE 10.2.0.."

SAP database version. 700

Operating system..... "Windows NT 5.0, Windows NT 5.1, Windows NT 5.2"

Memory consumption

Roll.... 8176

EM...... 3135672

Heap.... 0

Page.... 0

MM Used. 2660632

MM Free. 473408

User and Transaction

Client.............. 800

User................ "SAPUSER"

Language key........ "E"

Transaction......... "FB01 "

Program............. "SAPLGLIU"

Screen.............. "RSM13000 3000"

Screen line......... 2

Information on where terminated

Termination occurred in the ABAP program "SAPLGLIU" - in "INS_FAGLFLEXA".

The main program was "RSM13000 ".

In the source code you have the termination point in line 1199

of the (Include) program "LGLIUF1A".

The program "SAPLGLIU" was started in the update system.

The termination is caused because exception "CX_SY_OPEN_SQL_DB" occurred in

procedure "INS_FAGLFLEXA" "(FORM)", but it was neither handled locally nor

declared

in the RAISING clause of its signature.

The procedure is in program "SAPLGLIU "; its source code begins in line

1184 of the (Include program "LGLIUF1A ".

former_member184992
Active Contributor
0 Kudos

Hi,

Thanks a lot for the information about the dump. It really helped.

Please check the number range available in SPRO -> Financial accounting -> Financial accounting new -> Financial accounting global settings -> Documents in General ledger view -> Define document number ranges for General ledger view the following is present for company code

You can manually adjust the number range if you see clearly that the number range exceeded the limit that you have customized in this part of your SPRO.

There is also note 1538860 which resolved exactly the same dump in other installations even if the description does not reflect exactly your issue.

Best Regards,

Vanessa.

Former Member
0 Kudos

I have 3 GLs (leading/ 2 non leading). when i post directly to non leading ledger groups through FB01L, it works. so the problem is only with the leading ledger which i can access through FBN1. right? I only have to worry about . Also, I can't view the number range for leading ledger through the path you gave. I checked range intervals in FBN1. it all looked fine.

now, my question is that lets say only range interval 11 was overlapping with another interval. only that document type should be disallowed from posting right? Why would purchase invoice with a separate assigned number range interval be disallowed?

Also, I have been hearing this refer to note ______etc for a while. What does that mean? Does it give further guidance or something. Would i be able to find it on SAP's website for free?

Answers (3)

Answers (3)

Former Member
0 Kudos

I seen that error after client copy multiple times. The error we discovered was due to Controlling Document Number ranges.

The last controlling document number was greater than the last used number in the number range.

Former Member
0 Kudos

HI Vanessa,

I do not get anything more specific than that. after i post a document, I get a message document 1234 has been posted. when i go to display, it says this document doesnt exist. 2 mins later, i get a popup or message that update was terminated. it takes me to the inbox and i gave you the script of the error. this happens in every transaction code where a posting is possible. the only other information i can give you is the update key. Would you like to see that? Is there another area where I can give you more details? please help me out.. I don't really have an ABAP guy to help me out.

vivek_srivastava12
Active Contributor
0 Kudos

Hi,

There is the duplicate record updated in BSEG & BKPF table at the time of Posting the Transaction... most probable reason will document number..

Please check the document type you are using and its number range and last used number range... Please take help of ABAP consultant...

Br,Vivek

Former Member
0 Kudos

Vivek,

also, i dont think the problem is with numbe range. as it is, the intervals look fine and there is plenty of space. i tried to post another new company code. i have the same problem.