cancel
Showing results for 
Search instead for 
Did you mean: 

TREX error Index does not exist;index=saf:cda_350_kaen in knowledge search

Former Member
0 Kudos

Hi,

Please help me any body i got below error in knowledge search in web ui

TREX error Index does not exist;index=saf:cda_350_kaen in knowledge search

i have been completed all Knowledge base settings in Name and Configure Knowledge Base

Application settings in Configure Application. but still iam getting above error.

Regards,

kanth

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

CLOSE

Former Member
0 Kudos

did you resolve? I get the same error, oss note 1091759 explains how to resolve but wasn't working for me.

Does KA use STANDARD search engine and and SDB knowledge base?

At IMG location CRM > Enterprise Intelligence > Software Agent Framework, check:

1. The knowledge base has been configured - "Name and Configure Search Engine".

2. The knowledge base has been included in application - "Configure Application". The knowledge base should be in both application "ALL" and "ICWEBClient".

Then give the knowledge base a full compilation.

Former Member
0 Kudos

Hi

It is right solution.As per our requirement KA not required. we use only standard knowledge base sdb sdb problems sdb solutions, sdb solution doc. if required KA Then it is useful for your points.

Thnks for your solution.

Regards,

KANTH

Former Member
0 Kudos

Use the TCode: CRMC_SAF_TOOL to compile knowledge article in CRM SAPGUI. Press F8(to compile Knowledge Base). CRM WebUI page is started in the browser and here you can compile the your KA. Afterwards this error will not appear anymore.

Edited by: drabas on Aug 19, 2010 9:44 AM

Former Member
0 Kudos

Hi Kanth,

Check the RFC connection test for trex server.Whether connection test is green or not.(sm59->tcp/ipconnections->trex rfc).

Now spro->Enterprise intelligence->Softwareagent frame work->Configure RFC destination.Now whatever RFC destination is defined in sm59 should be the same .After doing all this settings,Compile the knowledge base once again.

Hope this answer will be helpfull to you.

Best Regards,

Silpa.T