Showing results for 
Search instead for 
Did you mean: 

MAS Generator Service Initialization Failed

Former Member
0 Kudos


We ar eon MSV 5.0 SP11. In MAS we are able to login to the MAS. The MAS creadentials are accepted, we get the screen where we can select the change list. When we click OK here, we get an error saying "Generator Service Initialization Failed".

This used to work earlier. Only change which is done is that the User with which we used to connect to the Windows machine (not MAS user)initially was a local user with admin rights. Now we are using the user with same username but the user is created on our Active directory server.

Can anyone guide us please?



Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

MAS needs Administrator previlage to run. (Administrator previlage of the system in which it is installed not that of the domain)

Add / Assign local Administrator privilage to the user (the one that u have created in the Active Directory).

Right click on My Computer ->Manage

Go to Local Users and Groups - >Group

Right click on Administrators -> Add to Group

Find and Add the user (the one that u have created in the Active Directory)

Click OK and close the window..

Make sure the SQL Server that ur MAS is connecting to is up and running....

Hope this will solve your problem...



Answers (1)

Answers (1)

Former Member
0 Kudos


"Generator Service Initialization Failed" error is because Genservicewrapper.dll is not registered properly.

To resolve this, Go to

<<Drive>>:\Program Files\Microsofy Visual Stusio 8\Common7\IDE folder

Register the dll Genservicewrapper.dll using the regsvr32 command.



Former Member
0 Kudos

Hi Shankar,

I'm having the same issue with the Generator Service. I've tried registering all the dll's in the Bin.Net folder and also registering Genservicewrapper. dll in <<Drive>>:\Program Files\Microsofy Visual Stusio 8\Common7\IDE.

I used the command "for %%f in (.ocx,.dll) do regsvr32.exe /s %%f" inside a batch file for registering the ocx's and dll's but the same error is still appearing and I cannot generate the application.

Do you know anything else I can try?

Thanks a lot!