cancel
Showing results for 
Search instead for 
Did you mean: 

IC Web Client - Transaction Launcher

Former Member
0 Kudos

Hello All,

In Interaction Center Web Client, I want to launch BOR transactions. I have configured Transaction Launcher and also Navigation Bar Profile.

But still when I click on the link at the left hand panel, I get the under stated error: -

404 Not Found

SAP J2EE Engine/7.00

The requested resource does not exist.

Details: Go to main page of this application!

Kindly do help.

Regards,

Khushboo

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Khushboo,

Probably this should help you:

CRM - ICWC New Navigation Link is not working

Posted: Nov 3, 2006 10:03 AM Reply E-mail this post

Hello Every one,

I am following the steps of Cookbook PDF Point Number 3.4, to add new view and change the navigation link to my new SimpleActivity view. I followed all the steps but i am unable to navigate to the new view.

I am getting the link on the navigation bar but it is not navigating to the new view.

Can anybody tell how can I move forword.

Regards,

Kuldeep.

Raja G

Posts: 76

Questions: 14

Registered: 6/9/05

Forum points: 98

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 3, 2006 11:56 AM in response to: Kuldeep Verma Reply E-mail this post

Hi Kuldeep,

You need to create a navigation link from the view where you aer calling SimpleActivity view to your view. Have you also completed steps 3.4.4. It talks about creating navigation link to the SimpleActivity view.

Regards

G.Raja

Kuldeep Verma

Posts: 43

Questions: 16

Registered: 8/28/06

Forum points: 2

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 3, 2006 12:20 PM in response to: Raja G Reply E-mail this post

Hi Raja,

Thanks for reply.

I have done the given step i.e. 3.4.4 but still its not working.Please help .

Thanks in advance.

Regards

kuldeep

sudeep vd

Posts: 56

Questions: 27

Registered: 9/6/06

Forum points: 2

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 4, 2006 2:59 PM in response to: Kuldeep Verma Reply E-mail this post

Hai kuldeep,

Can you explain me in detail.. what are the steps u have done for creating a navigation link? so that i can tell if u are missing something!.

Best Regards,

sudeep v d..

Raja G

Posts: 76

Questions: 14

Registered: 6/9/05

Forum points: 98

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 6, 2006 9:52 AM in response to: Kuldeep Verma Reply E-mail this post

Hi Kuldeep,

Go to the method GET_NAVIGATION_TARGETS of class CL_BSP_WD_REP_VIEW. Keep the breakpoint at Line 12 and check whether the SY-SUBRC is 0. If the sy-subrc is not equal to 0 then the navigation link XML file is not added to the runtime repository. Add the XML file to the runtime repository and check it again.

Regards

G.Raja

Kuldeep Verma

Posts: 43

Questions: 16

Registered: 8/28/06

Forum points: 2

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 14, 2006 11:04 AM in response to: Raja G Reply E-mail this post

Hello Raja,

That was very Helpfull answer that you have given, and i am able to add the navigation link. But now when i add new Fresh link that is "Testing124" it is not showing the view. I debug and find that when i click other navigation link one table "viewarea_cont "in the method Bind_View it is filling with the view id

1- SimpAct

2- Test124

these two are the view area id that is assigned in the ZZ_CRM_IC_DT_REP in the xml file SimpleActivitySet.xmL and Testing124Set.xml.

but when i click on Testing124 the table "viewarea_cont" is initial. that is why i am not getting the view.

Can you tell me how that table can be fill, so that i forward further.

Regards

Kuldeep

Raja G

Posts: 76

Questions: 14

Registered: 6/9/05

Forum points: 98

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 15, 2006 12:11 PM in response to: Kuldeep Verma Reply E-mail this post

Hi Kuldeep,

For this Testing124Set, you have to create one view (i.e., .htm file) and in that htm file, add the view area. You can refer any standard viewset for this information. Also this Testing124Set should be added to workviewset, otherwise it will not appear in the workviewarea.

Regards

G.Raja

Kuldeep Verma

Posts: 43

Questions: 16

Registered: 8/28/06

Forum points: 2

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 15, 2006 12:27 PM in response to: Raja G Reply E-mail this post

Hello Raja,

I have already make the htm file for Testing123set.do controller. and also set in the workview area

i am pasting the real code

-

-


Testing124Set.htm

-

-


<%@page language="abap" %>

<%@extension name="htmlb" prefix="htmlb" %>

<%@extension name="xhtmlb" prefix="xhtmlb" %>

<%@extension name="crm_bsp_ic" prefix="crmic" %>

<%@extension name="bsp" prefix="bsp" %>

<crmic:gridLayout cellPadding = "0"

cellSpacing = "2"

columnSize = "1"

rowSize = "1"

width = "100%"

height = "100%" >

<crmic:gridLayoutCell columnIndex = "1"

rowIndex = "1"

width = "100%"

height = "34%" >

<bsp:call comp_id = "<%= controller->GET_VIEWAREA_CONTENT_ID('Test124')%>"

url = "<%= controller->GET_VIEWAREA_CONTENT_URL('Test124')%>" />

</crmic:gridLayoutCell>

</crmic:gridLayout>

-

-


-

-


Design time

ZZZ_CRM_IC_DT_REP

-

-


CRM_IC_All_NavLinks.xml

-

-


<%@ include file="../CRM_IC_DT_REP/CRM_IC_All_NavLinks.xml" %>

<%@ include file="NavBarNavigationalLink.xml" %>

-

-


-

-


-

-


CRM_IC_All_Viewsets.xml

-

-


<%@ include file="MainViewSet.xml" %>

<%@ include file="../CRM_IC_DT_REP/BuPaViewSet.xml" %>

<%@ include file="../CRM_IC_DT_REP/CRM_IC_All_Viewsets_wo_BUPA_and_Main.xml"

%>

<%@ include file="SimpleActivitySet.xml" %>

<%@ include file="Testing124Set.xml" %>

-

-


-

-


-

-


MainViewSet.xml

-

-


-

-


-

-


NavBarNavigationalLink.xml

-

-


-

-


-

-


-

-


-

-


SimpleActivitySet.xmL

-

-


-

-


-

-


-

-


Testing124Set.xml

-

-


-

-


I am getting the following error.

View Testing124Set.htm Cannot Be Displayed

An Exception Occurred

Exception Class CX_BSP_INV_PAGE

Text: BSP Exception: Das Objekt empty.do in der URL /sap(bD1lbiZjPTAwMSZkPW1pbg==)/bc/bsp/sap/zz_crm_ic/Testing124Set.do ist nicht gültig.

Program: CL_BSP_PAGE_BASE==============CP

Include: CL_BSP_PAGE_BASE==============CM01A

Source Text Row: 117

Raja G

Posts: 76

Questions: 14

Registered: 6/9/05

Forum points: 98

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 15, 2006 2:00 PM in response to: Kuldeep Verma Reply E-mail this post

Hi Kuldeep,

Remove the namespace "ZZ_CRM_IC" from all the places where you have added it. In the Runtime framework repository, add the replaced controller as

CRM_IC - SimpleActivitySet - <<your BSP application>> - SimpleActivitySet

Instead of having the name as SimpleActivitySet. You can start with Z-namespace. Not required here but in general you can do that.

Regards

G.Raja

Kuldeep Verma

Posts: 43

Questions: 16

Registered: 8/28/06

Forum points: 2

Re: CRM - ICWC New Navigation Link is not working

Posted: Nov 16, 2006 7:31 AM in response to: Kuldeep Verma Reply E-mail this post

Thankyou Experts helping me to solve my problem. At last i have done one small mistake that is why i was not able to solve it. The problem was in Design time repository in file "Testing124Set.xml" i leaved a spelling mistake in that file that is why i am getting the problem.

At last i have solve it.

Thank you

Again.

Regards

Kuldeep

Answers (1)

Answers (1)

Former Member
0 Kudos

Found out a way of launching transactions successfully.

Regards,

Khushboo