cancel
Showing results for 
Search instead for 
Did you mean: 

CRM 2007 UI: Blank screen after selecting the profile

Former Member
0 Kudos

Dear all,

we installed CRM 2007 UI with the newest components.

After selecting one of the standard roles just a blank screen appears.

We checked all the notes and questions here:

- The profile parameter in RZ11 are set

- The services according to the notes are active

- We set browser security to low

- All relevant ports are open

- User role and profile is assigned to organizational unit

Still nothing. I know that others had this problem?

Have you come up with a solution?

Thanks

Andreas

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

How did u assingn User role and profile is assigned to organizational unit?

What role have u assigned? is that DEFAULT or custom one?

once u assign the DEFAULT role, u should be able to see all the Business Roles.. like IC_AGENT, IC_MANAGER... etc...

also, how are you launching ur Web UI?

try with SE80, and BSP application.. crm_ui_frame.

reward points if helpful,

Robin

Former Member
0 Kudos

There is no DEFAULT role. But we used various standard roles like SALESPRO or MARKETINGPRO.

The business roles are assigned to the respective organisational unit. We looked at authorisation profiles in PFCG, they look fine. The roles are visible after the log-in.

We tried both starting crm_ui_frame with SE80 and the service in SICF. Does not work neither.

One thing we observed: When we enter components in bsp_wd_cmpwb we get the error message "error interpreting the runtime repository".

Thanx for your help

Former Member
0 Kudos

Hi,

we found the error.

Authorizations object for the UI components were missing.

We copied the standard values with SU25 and implemented note 1120400.

Then authorization objects beginning with UIU are visible. It seems that you have to provide authorizations for each component in the UI framework.

Regards Andreas

Former Member
0 Kudos

Hi Andreas,

We are currently experiencing the same issue as you did, a blank page appears once we logged into WebClient.

What do you mean by "We copied the standard values with SU25"

Thanks for your help,

Regards,

Aldo

Former Member
0 Kudos

Hi Aldo,

SU25 is necessary for using the profil generator.

All the standard values are stored in SAP tables (USOBX, USOBT). In order to get all the standard authorization values you need to copy the entries in this tables to your customer tables (USOBX-C, USOBT-C). When you don't fill the customer tables initially there are a lot of authorization objects and values not activated, especially for object UIU_COMP. Thereore in our case tthe sceen was blank.

Look at the IMG-Documentation for "Define Userrole" and "Define authorization role". There the steps are explained in detail.

Also look at the building block "C04_BB_ConfigGuide_EN_DE".

Regards

Andreas

Former Member
0 Kudos

Hi Andreas,

This happened for us as well, but we were able to solve it.COuple of things that you might want to check

a)Check RZ11 for sso* things as per the note

b)Do Su25 entries and apply the note which uploads a text file.

c)Deactivate S_SERVICE auth object from your role.

d) and the MOST IMPORTANT one is to check the patch level for your system. Goto transaction "SPAM" and select "All Support Packages" and hit Display. Under the node "SAP_BASIS" what is the latest patch you are seeing. Ideally it should be 14. This was the reason why we were not getting the CRM 2007 screen to work. After applying the patch it worked.

Reward points if it helps.

Thanks,

Anand

Former Member
0 Kudos

Hi,

might be helpful for Aldo.

We resolved this error. We also implemented the new SP's, thats necessary too.

Regards

Andreas

Former Member
0 Kudos

Hi, thanks for your replies,

Our SP is uptodate,

Note 1120400 is obsolete we have CRM 6 SP2 and our patch level is 15.

Besides we have a delta between tables entries:

USOBX => 103.391

USOBX_C => 103.389

and

USOBT => 43.785

USOBT_C => 43.769

Do these tables have the same number of entries in your system? What could be the impact of this delta?

Thanks,

Aldo

Former Member
0 Kudos

Hi,

yes, we have a couple of table entries less in the customer tables as well.

Regards

Andreas

Former Member
0 Kudos

Aldo,

Could you able to resolve the issue?

We are still working on the issue.,

Thanks in Advance,

Answers (0)