cancel
Showing results for 
Search instead for 
Did you mean: 

'Wheel of death' doesn't appear on custom application

former_member206638
Participant
0 Kudos

Hi experts.

I'm going through an unusual situation here.

I've developed a custom component (Search view + Search results), and after pressing button 'Search' I was expecting / wishing to see the famous so-called 'wheel of death' animated gif while waiting the search results.

I've been debugging CL_THTMLB_SUBMITINPROGRESS-DO_AT_BEGINNING method, and nothing seems to be wrong there, the programming logic takes expected paths in runtime, though the animated gif is not shown.

Maybe the problem is in my page layout html code, take a look at a simplified version of it, with only the tags structure it has now:


<%@page language="abap" %>
<%@extension name="htmlb" prefix="htmlb" %>
<%@extension name="thtmlb" prefix="thtmlb" %>
<%@extension name="chtmlb" prefix="chtmlb" %>
<%@extension name="xhtmlb" prefix="xhtmlb" %>
<%@extension name="phtmlb" prefix="phtmlb" %>
<%@extension name="bsp" prefix="bsp" %>

<chtmlb:pageType type="SEARCH" >
      <thtmlb:searchFrame > >
        <thtmlb:searchCriteriaFrame>
          <thtmlb:searchArea>
            <thtmlb:searchTagArea>
              <thtmlb:advancedSearch/>
            </thtmlb:searchTagArea>
            <thtmlb:searchSavingArea>
*              Reusing here component CRM_SAVEDSEARCH view Registration
            </thtmlb:searchSavingArea>
            <thtmlb:searchButtonsArea>
              <thtmlb:button/>
            </thtmlb:searchButtonsArea>
          </thtmlb:searchArea>
        </thtmlb:searchCriteriaFrame>
        <thtmlb:searchResultFrame>
          <htmlb:tabStrip id="TabStrip1" >
             <htmlb:tabStripItem id    = "TabItem1">
               <htmlb:page>
                 <chtmlb:configCellerator/>
              </htmlb:page>
             <htmlb:tabStripItem id    = "TabItem2">
               <htmlb:page>
                 <chtmlb:configCellerator/>
              </htmlb:page>
            </htmlb:tabStripItem>
          </htmlb:tabStrip>
        </thtmlb:searchResultFrame>
      </thtmlb:searchFrame>
    </chtmlb:pageType>

Any idea of what is missing / wrong?

Thanks in advance.

FSA

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member206638
Participant
0 Kudos

Any idea guys?

I still couldn't find anything new...

Thanks in advance.

FSA

joaquin_fornas
Active Contributor
0 Kudos

Hola!

Everything looks fine from your code, so I am curious about a couple things:

- Does it happen to all your views or only to your custom one?

- Which IE are you using? Have you tried another browser or another version?

- May sound stupid, but check that flag personalize->settings->Personalize settings->screen reader mode->Enable additional support for screen reader is OFF.

- Also, apply note 1516972

Regards

Joaquin

former_member206638
Participant
0 Kudos

Hi Joaquin.

Thanks for your time.

- Does it happen to all your views or only to your custom one?

It only happens with 'Z' views from my 'Z' component (it's an entirely Z application). All the rest of standard components and views, they show the spinning wheel.

- Which IE are you using? Have you tried another browser or another version?

I'm using 9, but on previous versions is the same behaviour.

- May sound stupid, but check that flag personalize->settings->Personalize settings->screen reader mode->Enable additional support for screen reader is OFF.

It's OFF.

- Also, apply note 1516972

This is not really the point. System performance is quite acceptable, even though a couple of tasks are supposed to be time consuming, and that's when we expect the wheel to be shown to avoid the user to click on 'Submit' again and again, sendig server requests all the time.

Other ideas?...

FSA