cancel
Showing results for 
Search instead for 
Did you mean: 

WEC 1.0 Cart View vs. Checkout View Taxes amount

Former Member
0 Kudos
59

Hi dear experts.

We are working over WEC 1.0, we noted that even for a standard shop, the behavior for the Taxes amount between the Cart View and the Checkout View is different, when the user is logged, select a product, and goes to the Cart View the Taxes amount is zero, then if the user goes to the Checkout View the Taxes amount is calculated according to the percentage configuration, just as follow.

  1. The user select a product from the catalog, please note that it is a standard shop.
  2. If the user goes to the cart view the Taxes amount isn´t displayed as the user is not logged in yet.
  3. The user goes to the checkout view, the user name and password are requested, the taxes amount is showed as zero, and however the shipping amount is already calculated.
  4. The user logs into the shop and the correct taxes amount is displayed.
  5. The user (still logged in) goes back to the cart view and the taxes amount is displayed as zero, however the shipping amount is kept.

Obviously this affect the Order Total amounts.

Why does this happen?

Is there a way to activate the Taxes calculation for the Cart View?

Any suggestion is very welcome.

Best regards.

Accepted Solutions (1)

Accepted Solutions (1)

prashil
Advisor
Advisor
0 Kudos

Hi Abner,

I still this is standard behaviour and it makes to have it like that.

I think for taxes to calculate we should have the user/soldto/shipto and other business partner details.

What I believe is cart is work area where user can fill all the required entities and checkout is the summary/preview of the actual order process where the complete entities like material, business partner are determined and evaluated.

regards

Prashil

P.S. Also check if you have late basket selection enabled (not sure if WCEM supports late and early basket selection).

Message was edited by: Prashil Wasnik

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi there

Thank you very much Prashil and Karsten for the response, the problem is now solved, the reason was a configuration issue, in particular a formula which was calculating the pricing incorrectly.

Best regards.

Abner.

KaHa
Advisor
Advisor
0 Kudos

Hi Abner,

could you please provide a pricing trace from step 5?

Regards,

Karsten