cancel
Showing results for 
Search instead for 
Did you mean: 

WCEM20 CBS Build finished with ERROR

Former Member
0 Kudos

Hi All

I am workig with WCEM2.0 and after changing the look and feel of the shop I checked in and activated the activities. I had some requests created and built by the CBS ending with the following errors:

1. Creating Ant build file..

  Creating output file: E:\usr\sap\XXX\J00\j2ee\cluster\server0\temp\CBS\9215450\6\.B\2248\DCs\com\comm\main\leanwebapp\cust_theme\_comp\gen\default\logs\build.xml

  Using Java class:     com.sap.tc.buildplugin.BuildWebModule

com.sap.tc.buildplugin.util.BuildPluginException: Web XML file E:\usr\sap\XXX\J00\j2ee\cluster\server0\temp\CBS\9215450\6\.B\2248\DCs\com\comm\main\leanwebapp\cust_theme\_comp\WebContent\WEB-INF\web.xml cannot be read.

at com.sap.wec.tc.core.build.MergeWebXMLTarget.checkMergeWebXMLComment(MergeWebXMLTarget.java:299)

at com.sap.wec.tc.core.build.MergeWebXMLTarget.render(MergeWebXMLTarget.java:120)

at com.sap.tc.buildplugin.ant.util.AntBase.renderExtensionTarget(AntBase.java:1348)

at com.sap.tc.buildplugin.ant.util.AntBase.prepareExtensionTargets(AntBase.java:1307)

at com.sap.tc.buildplugin.ant.util.AntBase.end(AntBase.java:277)

at com.sap.tc.buildplugin.ant.util.AntDelegator.completeBuildFile(AntDelegator.java:142)

I checked the folder  "......9215450\6\.B"  is empty. Any advise?

Regards

MG

View Entire Topic
ralf_detzler
Explorer
0 Kudos

I don't know exactly how your DC setup is. So first we can check the provided error message. It states, that the web.xml file is missing in the folder WebContent\WEB-INF in  DC com/comm/main/leanwebapp/cust_theme. Can you please tell, if this is correct? Please check the source code in this DC and check also, if this file is checked in.

Thanks and regards

Ralf

Former Member
0 Kudos

Hi Ralf

I can see the file in the NWDS via all the perspective DTR included. I managed to add it again to the repository creating a new activity which then I have checked in and activated. Right now I am waiting for the request that got created after activation to be built by CBS. It is taking quite long, waiting since yesterday, any way to speed it up?

Regards

MG

Former Member
0 Kudos

I assume your web.xml issue is now solved only the build is not running.

You might have to go to the NWDI=> CBS and check your activity queue. If it runs too long, then you might have bigger issues. Sometimes it helps to restart the NWDI machine.

Btw. how did you create your module? Did you not use the Module Wizard to create it? This shoud have created all modules including DPU part.

Former Member
0 Kudos

Hi Andreas

after restarting the NWDI I finally have the request built, thank you. However the result is not positive and could be related to previous failed requests:

.. FAILURE: DC Build variant default of

Development Component

"com/comm/main/leanapp/cust_theme" in compartment "com_THEME" attached to request 997

[scID: 56, dcID: 764, parent dcID: 0, current state: OK, action: CREATED]

Build Number: (last successful: 0, last known 0)

cannot be build as the following used DC build variants are broken:

Build variant default of

Development Component

"com/comm/main/leanwebapp/cust_theme" in compartment "com_THEME" attached to request 997

[scID: 56, dcID: 762, parent dcID: 0, current state: OK, action: CREATED]

Build Number: (last successful: 0, last known 2,260)

In terms of how I have created the extension of the module, yes I used the wizard and got the DPU as well. Deployed in development and perfectly working, I am wondering why the problem in CBS.

Regards

MG

Former Member
0 Kudos

Hi,

so you can build your modules locally without issues? (Open the Infrastructure Consule before doing the build to see erros)

I experienced already the case, that modules are only created locally. It might have happened, that you did not upload all modules to the NWDI and hence the build fails.

If I can locally not find any issue, then you need to open the CBS and locate the damaged DC. Not necessary the first broken DC is the reason. Follow the path of the broken child DCs so that you find the one, which is broken. Open the build log and send it to us, there must tbe the error listed.

Regards,

Andreas