cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading to SAP Commerce Cloud 2211.23/2211.24

stefanweis
Participant
459

Hello,

I am still trying to update SAP Commerce Cloud from 2211.20 to 2211.24. According to this (https://help.sap.com/docs/SAP_COMMERCE_CLOUD_PUBLIC_CLOUD/75d4c3895cb346008545900bffe851ce/5a0017807...), Solr 9.5 should now be included within the platform for local development environments. Yet, when I run ant all, it is still trying to download Solr 9.5 and its not using the one from solr-hybris-customizations.

I have also set the following property (only for local environments): solrserver.solr.server.version=9.5.8

Here the log:

     ...
     [echo] building extension 'searchbackoffice'...
     [echo] building extension 'smartedittools'...
     [echo] building extension 'solrfacetsearch'...
     [echo] Skipping all Smartedit extensions build due to smartedittools.only.build.once=true
     [echo] Registered searchbackoffice as SASS extensions
     [echo] Registered searchbackoffice as SASS extensions
     [echo] building extension 'adaptivesearchsolr'...
     [echo] building extension 'customadaptivesearch'...
     [echo] building extension 'solrfacetsearchbackoffice'...
     [echo] Registered solrfacetsearchbackoffice as SASS extensions
     [echo] Registered solrfacetsearchbackoffice as SASS extensions
     [echo] building extension 'adaptivesearchbackoffice'...
     [echo] building extension 'backofficesolrsearch'...
     [echo] building extension 'solrserver'...
     [echo] building extension 'springintegrationlibs'...
     [echo] building extension 'tomcatembeddedserver'...
     [echo] building extension 'ticketsystembackoffice'...
     [echo] building extension 'voucher'...
     [echo] Registered adaptivesearchbackoffice as SASS extensions
     [echo] Registered adaptivesearchbackoffice as SASS extensions
     [echo] Registered ticketsystembackoffice as SASS extensions
     [echo] Registered ticketsystembackoffice as SASS extensions
     [echo] --- Solr customizations 8.11 ---
     [echo] expectedVersion: 8.11.49
     [echo] currentVersion: 8.11.49
     [echo] --- Solr customizations 9.2 ---
     [echo] expectedVersion: 9.2.23
     [echo] currentVersion: 9.2.23
     [echo] --- Solr customizations 9.5 ---
     [echo] expectedVersion: 9.5.8
     [echo] currentVersion: 9.5.8
     [echo] --- Solr server 9.5 ---
     [echo] expectedVersion: 9.5.8
     [echo] currentVersion: 
     [echo] expectedCustomizationsVersion: 9.5.8
     [echo] currentCustomizationsVersion: 
     [echo] Installing Solr server [version=9.5.8, type=zip, customizationsVersion=9.5.8]
[artifact:dependencies] Downloading: org/apache/solr/solr/9.5.8/solr-9.5.8.pom from repository custom_nexus at https://mvn.intern.custom.de/repository
[artifact:dependencies] Error transferring file: mvn.intern.custom.de
[artifact:dependencies] [WARNING] Unable to get resource 'org.apache.solr:solr:pom:9.5.8' from repository custom_nexus (https://mvn.intern.custom.de/repository): Error transferring file: mvn.intern.custom.de
[artifact:dependencies] Downloading: org/apache/solr/solr/9.5.8/solr-9.5.8.pom from repository central at https://repo1.maven.org/maven2
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.solr:solr:pom:9.5.8' in repository central (https://repo1.maven.org/maven2)
[artifact:dependencies] Downloading: org/apache/solr/solr/9.5.8/solr-9.5.8.zip from repository custom_nexus at https://mvn.intern.custom.de/repository
[artifact:dependencies] Error transferring file: mvn.intern.custom.de
[artifact:dependencies] [WARNING] Unable to get resource 'org.apache.solr:solr:zip:9.5.8' from repository custom_nexus (https://mvn.intern.custom.de/repository): Error transferring file: mvn.intern.custom.de
[artifact:dependencies] Downloading: org/apache/solr/solr/9.5.8/solr-9.5.8.zip from repository central at https://repo1.maven.org/maven2
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.solr:solr:zip:9.5.8' in repository central (https://repo1.maven.org/maven2)
[artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
[artifact:dependencies]  Diagnosis:
[artifact:dependencies] 
[artifact:dependencies] Unable to resolve artifact: Missing:
[artifact:dependencies] ----------
[artifact:dependencies] 1) org.apache.solr:solr:zip:9.5.8
[artifact:dependencies] 
[artifact:dependencies]   Try downloading the file manually from the project website.
[artifact:dependencies] 
[artifact:dependencies]   Then, install it using the command: 
[artifact:dependencies]       mvn install:install-file -DgroupId=org.apache.solr -DartifactId=solr -Dversion=9.5.8 -Dpackaging=zip -Dfile=/path/to/file
[artifact:dependencies] 
[artifact:dependencies]   Alternatively, if you host your own repository you can deploy the file there: 
[artifact:dependencies]       mvn deploy:deploy-file -DgroupId=org.apache.solr -DartifactId=solr -Dversion=9.5.8 -Dpackaging=zip -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
[artifact:dependencies] 
[artifact:dependencies]   Path to dependency: 
[artifact:dependencies]         1) org.apache.maven:super-pom:pom:2.0
[artifact:dependencies]         2) org.apache.solr:solr:zip:9.5.8
[artifact:dependencies] 
[artifact:dependencies] ----------
[artifact:dependencies] 1 required artifact is missing.
[artifact:dependencies] 
[artifact:dependencies] for artifact: 
[artifact:dependencies]   org.apache.maven:super-pom:pom:2.0
[artifact:dependencies] 
[artifact:dependencies] from the specified remote repositories:
[artifact:dependencies]   central (https://repo1.maven.org/maven2),
[artifact:dependencies]   custom_nexus (https://mvn.intern.custom.de/repository)
[artifact:dependencies] 
[artifact:dependencies] 

BUILD FAILED
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/build.xml:13: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/compiling.xml:95: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/compiling.xml:136: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/util.xml:42: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/util.xml:44: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/compiling.xml:143: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/compiling.xml:421: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/platform/resources/ant/util.xml:142: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/modules/search-and-navigation/solrserver/buildcallbacks.xml:164: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/modules/search-and-navigation/solrserver/buildcallbacks.xml:213: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/modules/search-and-navigation/solrserver/buildcallbacks.xml:310: The following error occurred while executing this line:
/Users/sweis/dev/shop-platform/server/hybris/bin/modules/search-and-navigation/solrserver/buildcallbacks.xml:412: Unable to resolve artifact: Missing:
----------
1) org.apache.solr:solr:zip:9.5.8

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.solr -DartifactId=solr -Dversion=9.5.8 -Dpackaging=zip -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.solr -DartifactId=solr -Dversion=9.5.8 -Dpackaging=zip -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
        1) org.apache.maven:super-pom:pom:2.0
        2) org.apache.solr:solr:zip:9.5.8

----------
1 required artifact is missing.

for artifact: 
  org.apache.maven:super-pom:pom:2.0

from the specified remote repositories:
  central (https://repo1.maven.org/maven2),
  custom_nexus (https://mvn.intern.custom.de/repository)



Total time: 6 seconds

> Task :yall FAILED

FAILURE: Build failed with an exception.

* Where:
Script '/Users/sweis/dev/shop-platform/builder/buildsystem/hybris.gradle' line: 554

* What went wrong:
Execution failed for task ':yall'.
> Process 'command 'apache-ant/bin/ant'' finished with non-zero exit value 1

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Anyone has an idea what I'm doing wrong?

Thanks in advance! 

View Entire Topic
georg_wittmann
Explorer

Hi,

the bundled solr version is still 8.11 (see hybris/bin/modules/search-and-navigation/solrserver/resources/solr).

The version "9.5.8" is the version of the solr customizations. For solr there is just one 9.5.0 version so far.

Additional note: Solr zips are not in public maven repositories -> you have to download version 9.5.0 and pulish to your local maven repository.

stefanweis
Participant
0 Kudos
thank you, documentation is kind of confusing