cancel
Showing results for 
Search instead for 
Did you mean: 

target-system-publications error not showing by publicationId

Former Member
0 Kudos

Hi, We have recently migrated from 5.6 to 6.1.We are loading some products.When I check http://localhost:8080/datahub-webapp/v1/target-system-publications it shows COMPLETE_W_ERRORS as below:

     <publicationId>17</publicationId>
     <startTime>2016-10-24T16:56:53-05:00</startTime>
     <endTime>2016-10-24T16:56:55-05:00</endTime>
     <status>COMPLETE_W_ERRORS</status>
     <targetSystemName>HybrisCore</targetSystemName>
     <actionId>3</actionId>
     <poolName>GLOBAL</poolName>
     <numberOfErrors>0</numberOfErrors>
     <canonicalItemCount>19</canonicalItemCount>
 </targetSystemPublicationData>

So i checked Publication Error by Id i.e. http://localhost:8080/datahub-webapp/v1/target-system-publications/17/errors but I am getting .

Why it's not showing the errorDatas ?What property we have to set for the same? What is the restAPI to check the Publication Errors by ID in 6.1 ? In our other env we have 5.6 and /target-system-publications/{publicationId}/errors returns the errors for the publicationId why the same restAPI returning empty in 6.1. we have following properties set in both env. kernel.autoInitMode=update # cleanup datahub.cleanup.rawitem.enabled=false datahub.cleanup.canonicalitem.enabled=false datahub.cleanup.targetitem.enabled=false datahub.cleanup.publisheditems.enabled=false

former_member333910
Active Participant
0 Kudos

Can you attach the Data Hub log to this question? I'd like to look closely at it to understand what is happening and what scenario might cause this.

Run the simplest possible scenario where you can make this happen. Run with DEBUG level logging. Attach only the excerpt of the log that is relevant.

Former Member
0 Kudos

Hi ,

attched is the log. The COMPLETE_W_ERRORS is then why there is no errors. 0link text

Former Member
0 Kudos

We fixed this issue.Thanks.

former_member333910
Active Participant
0 Kudos

Good. What was the solution? It may help others.

Former Member
0 Kudos

The issue was ,we were getting a salesOrg/DistributionChannel which is not in our product CanonicalProductSalesAreaToCatalogMapping. So once i add the mapping in hmc for this combination i was able to see the 2. To fix this programmatically we created a custom stockFilterGroupingHandler and added logic to Remove bad salesorg/dc combos (not in CanonicalProductSalesAreaToCatalogMapping) now it publishes the Product with SUCCESS

Accepted Solutions (0)

Answers (1)

Answers (1)

mpern
Advisor
Advisor
0 Kudos

looks like sth else went wrong, because:

 <numberOfErrors>0</numberOfErrors>

Therefore, you will not get any error data...

Former Member
0 Kudos

So we should track from datahub log to check ? In which scenario this happens ?