cancel
Showing results for 
Search instead for 
Did you mean: 

SAP JVM for SAP Commerce 1905

bliegener
Participant
0 Kudos

Dear all,

as stated in the Third-Party Compatibility systems requirements for SAP Commerce 1905 (https://help.sap.com/viewer/a74589c3a81a4a95bf51d87258c0ab15/1905/en-US/8c71300f866910149b40c88dfc0d... SAP-Commerce 1905 requires a Java JDK version 11.0

I was wondering whether there is an SAP JVM for Version 11 available? In the Download Portal I can only find SAP JVM 8.1, which is at least Java version 8 I think (and not 11). So is there (or will there) be an SAP JVM for Java 11 available (soon)?

Best regards, Benedikt

View Entire Topic
former_member224482
Active Contributor
0 Kudos

I was wondering whether there is an SAP JVM for Version 11 available?
No.

So is there (or will there) be an SAP JVM for Java 11 available (soon)?
No.

For Java 11+, use SapMachine instead of SAP JVM.
The main difference is that SapMachine is based on OpenJDK.
You can see the list of SAP JVM features contributed into the SapMachine : Features Contributed by SAP

agrabovskis
Participant
0 Kudos

Third party compatibility matrix does not list SapMachine as supported JVM on any of operating systems, hence SapMachine cannot be considered for deployment to production. Obviously any compatible Java 11 JVM should work, but that needs to be explicitly stated in the official documentation.

bliegener
Participant
0 Kudos

Thanks for your answer!

And I totally agree with - We have a lot of customers who use the official Third-Party Compatibility matrix to check which JVM is supported and SapMachine is not listet there.

Former Member
0 Kudos

If you are using Commerce in the cloud, then you are limited to what they use there. Therefore, it might more sense to match your other development environments to the JDK installed on those CCV2 environments.

However, I don't know yet what JDK implementation SAP use in CCV2.

kamil_mrowiec
Explorer
0 Kudos

I was recently deploying to our SAP Cloud environment, and can confirm that it uses SapMachine JVM, at least that's what reported in logs.