cancel
Showing results for 
Search instead for 
Did you mean: 

Problems erasing marketing attributes after adding them by a code snippet

Former Member
0 Kudos

Hi experts,

The problem I'm facing occurs after adding some marketing attributes with the corresponding values to a BP using the FM 'CRM_MKTBP_CHANGE_BP'. I also tried the FM 'CRM_MKTBP_ASSIGN_ATTRIBUT'.

All this work is done properly but the problem starts when I access to the details of the BP, via WebUI, and try to erase the created marketing attributes. When i erase them all and press the save button, they appear again. Anything happens. The only way I have to erase them is using another FM, but it is impossible to do that via WebUI.

Any suggestion?

Thank you very much.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I have noticed a difference inserting a new marketing attribute from the webui and doing it by coding it.

When i insert manually from the WEBUI two new MA, if i look for the element in the AUSP table I can see that the given OBJEK value is the same for both elements. Everything works fine with these two MA.

When i insert a third element with a report i can see that the inserted element has a different OBJEK, and it is in this time when it is impossible to erase this third MA from the webUI.

Any clue?

Thank you.

Former Member
0 Kudos

At least I solved my problem.

It was very simple and stupid. I tried before but don't know why it didn't work.

I only had to execute a commit statement, like this.

 
DATA ls_return LIKE bapiret2.
* Remember to commit your changes
      CALL FUNCTION 'BAPI_TRANSACTION_COMMIT'
        IMPORTING
          return = ls_return.