cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Dynatrace agent not loading Hybris 6.7

arthurjs2
Explorer
0 Kudos

I am following the instructions on the help.hybris page: https://help.hybris.com/6.7.0/hcd/8bb51026866910148286d33495d1034f.html

I have added to my local.properties file the following

 ### DYNATRACE SETTINGS ###
 ### make sure to select the right platform and architecture for the JVM version
 # linux 64 bit
 dynatrace.agentlib=/opt/y/hybris/bin/platform/resources/dynatrace/agent/lib64/libdtagent.so
 
 ### name for the Hybris instance in dynatrace
 ### make sure this starts with 'hybris' to use with the dynatrace fastpack
 dynatrace.name=hybris-app
 
 ### IP adress or DNS hostname of the dynatrace server
 ### make sure the dynatrace server is reachable on port 9998
 dynatrace.server=*OURSERVER*:9998
 
 ### the full dynatrace JVM options
 dynatrace.jvm-opts=-agentpath:${dynatrace.agentlib}=name=${dynatrace.name},server=${dynatrace.server},wait=45

 tomcat.generaloptions=${dynatrace.jvm-opts}

Normal behaviour would be expected to see Dynatrace being loaded with hybris start-up:

 [native] ------------------------------------------------------------------------
 [native] dynaTrace Agent for Java Copyright (C) 2004-2014 Compuware Corporation
 [native] ------------------------------------------------------------------------
 [native] Trying to connect to Server for up to 60 seconds
 [native] Instrumentation channel connected successfully
 [native] Agent classes defined successfully
 [native] Platform .................... Windows Server 2008 6.0, amd64
 [native] Control channel connected successfully
 [native] Agent ID .................... 5ab231cf
 [native] Process ID .................. 3984
 [native] Recovery .................... enabled
 [native] Hot Sensor Placement ........ available

We do not get these messages in our log, Dynatrace is not being loaded.

After changes to local.properties, we have done ant server, ant build, ant clean all; nothing makes Dynatrace load.

Any ideas?

Accepted Solutions (1)

Accepted Solutions (1)

arthurjs2
Explorer
0 Kudos

EDIT

changing dynatrace.agentlib=/opt/y/hybris/bin/platform/resources/dynatrace/agent/lib64/libdtagent.so

to dynatrace.agentlib=/opt/y/hybris/bin/platform/resources/dynatrace/agent/lib64/libdtagent.dylib

seems to work for now

Answers (0)