cancel
Showing results for 
Search instead for 
Did you mean: 

Planning fields are set to read-only after mapping with TPM spend type

Former Member
0 Kudos
224

Hi Experts,

We are implementing Key Figure Planning for Trade Promotion.

On CRM side: ZEXP_ZT01 is mapping to an expense type ZT01. It is read-only in the planning layout when I click Planning in a trade promotion through Webui. But it is expected to be input ready for planning input purpose.

In BW-BPS side, we have the following planning objects that copied from standard BI content object by replace the beginning 4 with Z:

ZTPM9000 Multi area with single area ZTPM8000(point to realtime cube that copied from 0CP_SLSCA, data slice in ZTPM8000 deleted)

ZTPM9710 Planning layout on ZTPM9000

ZTPM9710 Planning Profile with ZTPM9000 and all sub-object


Key figure: ZEXP_ZT01 is created by template of 0AMOUNT, which is add to the real time cube and correspondingly planning level/layout.

In Planning Layout ZTPM9710, ZEXP_ZT01 is added in the data columns with comparison column unchecked. When I run the layout in BPS0, planning data can be uploaded into the real time cube.

In UPX_MNTN Key Figure Scheme tab, its display only checkbox is unchecked, nor there is any calculated key figures in the scheme. When I run preview in the tab beside key figure scheme tab, the field can be input.

What's weird is:

- It is not only read-only but also it won't read the planning amount in the cube(those I upload for BPS0 layout)

- when I clear the mapping to the expense type, it is inputable, but wont show the amount in the cube either, but the amount can be upload to the cube.


So from BW side, it is input ready, is there anything I missed to configure to make it input ready on the crm web ui?


Best Regards,

Geegee

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member196553
Active Contributor
0 Kudos

Hello,

are you using CRM or BI rates? When using CRM rates the trade spend value is to be edited in the trade spend assignment block directly, in that case the value is synchronized with BPS but not editable in the BPS planning layout. In case of BI rates the spend value can be edited in the planning layout only.

Please check the Define Rates' Origin customizing for TPM accordingly.

best regards,

Johannes

Former Member
0 Kudos

Hello Johannes,

I'm not sure about which rate I am using, and I consulted our CRM, she said something is adjusted as follow:

In SAP Customizing Implementation Guide -> Customer Relationship Management -> Trade Promotion Management ->Trade Promotions -> Trade Spends -> Define Trade Spends for Values we have following settings:

Under Spend Type ZTSC: Spend Type T01B is maintained with ZEXP_ZT01 in TS Category to TS type relationship maint.

Under Spend Type T01B: Spend Method REBATECASH is maintained with take rate key fiugure ZCDT_0001 in Spend Method, take rate, Off Invoice Cap.

Does it mean we use CRM rate?

Now ZEXP_ZT01 is read-only in layout, as you said it should be fine because the spend value should be transfer from trade spend assignment block. But still it cannot be correctly update with "transfer trade spend" function. If I enter the amount of spend value in trade spend assignment block, the ZEXP_ZT01 field will add by 1/00 of this spend value each time I click "transfer trade spend", which is very weird. Plus, the ZCDT_0001 will add by 1 each time I click "transfer trade spend".


Do you have any clue about it? Any suggestion from you must be really helpful.

Best Regards,

Geegee

Former Member
0 Kudos

sorry typo.

when I type spend value in trade spend assignment block, and click transfer trade spend, ZEXP_ZT01 will add by 1/100 of this value.