cancel
Showing results for 
Search instead for 
Did you mean: 

No type ExcelImportJob exists

kundan1986
Explorer
0 Kudos

Hi All,

While Hybris Upgrade from 6.4 to 1811 version, I'm getting below server start-up error.

Kindly let me know, how to resolve this issue?

ERROR [updateRuleBaseJob::de.hybris.platform.servicelayer.internal.jalo.ServicelayerJob] (updateRuleBaseJob) [HybrisApplicationEventMulticaster] No type ExcelImportJob exists de.hybris.platform.servicelayer.exceptions.UnknownIdentifierException: No type ExcelImportJob exists at de.hybris.platform.servicelayer.type.daos.impl.DefaultTypeDao.findTypeByCode(DefaultTypeDao.java:85) ~[coreserver.jar:?] at de.hybris.platform.servicelayer.type.impl.DefaultTypeService.isAssignableFrom(DefaultTypeService.java:591) ~[coreserver.jar:?] at com.hybris.backoffice.events.AbstractBackofficeCronJobEventListener.typesMatch(AbstractBackofficeCronJobEventListener.java:50) ~[backofficeserver.jar:?] at com.hybris.backoffice.events.AbstractBackofficeCronJobEventListener.eventMatchesInclude(AbstractBackofficeCronJobEventListener.java:40) ~[backofficeserver.jar:?] at com.hybris.backoffice.events.AbstractBackofficeCronJobEventListener.lambda$0(AbstractBackofficeCronJobEventListener.java:34) ~[backofficeserver.jar:?]

Accepted Solutions (0)

Answers (2)

Answers (2)

kundan1986
Explorer
0 Kudos

Hi ,

Thanks for replying to my query, but backoffice extension is already added in localextensions.xml

former_member620692
Active Contributor
0 Kudos

There is no harm in performing ant clean all updatesystem once again. Could you please do it again and let me know if it still doesn't work?

kundan1986
Explorer
0 Kudos

Hi @Arvind sir,

If I use default hybris hsql db which isn't initialized then i'm not getting this error (i.e. No type ExcelImportJob exists), where as if i use oracle db instance which was initailized in 6.4 then i'm getting this error and also ant clean all updatesystem failed.

Any Suggestions?

former_member620692
Active Contributor
0 Kudos

Hi - Please include backoffice in the localextensions.xml, perform ant clean all updatesystem and try again.