cancel
Showing results for 
Search instead for 
Did you mean: 

Missing z-fields in the WebUi view

Former Member
0 Kudos

Hi,

I have a problem with the view u201Esearch opportunitiesu201C

navigation: menu : Sales Cycle u2013 Search - Opportunities

component: BT111S_OPPT

view: Search

Itu2019s a customer configuration.

In this view is a different between the area u201CSearch Criteriau201D and the configuration tools.

When I open the configuration tool I can see in the area u201CSelected Search Criteriau201D three fields which arenu2019t in the area u201CSearch Criteriau201D on the view. This three fields are Z-attributes.

Does anybody know how I can display this fields?

Thank you in advance.

Best regards, Jasmin

View Entire Topic
Former Member
0 Kudos

Hi,

Generate the getter, setter,GET_M_xx & GET_I_xx methods and then check again.

Regards,

Shobhit

Former Member
0 Kudos

Hi Shobhit,

in the component workbench I navigated to:

context - context note - search - attribute -struct.z... (three z-attributes)

Then I generated the getter- and setter methods. Now each ot the three z-attributes have follow active getter and setter:

GET_M_(attribute name), GET_I_(attribute name), GET_(attribute name), SET_(attribute name).

I tested it in the WebUI. The z-attributes are still missing in the WebUI.

Do you have any other ideas?

Thank you for your help in different threads.

Best regards, Jasmin

Edited by: Jasmin on Oct 12, 2010 4:53 PM

Former Member
0 Kudos

Hi,

Go to change mode in the customer config and then you need to select the z-attributes from the left hand side (Available Attribute) and then move it to the right side 'Selected search criteria' using the arrow in between, also you can mark the display checkbox.

Regards,

Shobhit

prasenjit_sharma
Active Contributor
0 Kudos

Hi,

Try to reset the config by the the delete personalization report.

I think the report name is BSPDELETE*PERSONALIZATION

Regards

Prasenjit

Former Member
0 Kudos

Hi Experts,

thank you for your reply.

Shobhit, the z-attributes are already on the right side "Selected Search Criteria". Yeah, that's the stange.

For testing I would do this process again. That was my plan:

1. step: Now the z-attributes are on the right side "Selected Search Criteria". Then I would move this z-attributes to the left side "Available Search Criteria".

2. step: To move the z-attributes from the left side "Available Search Criteria" to the right side "Selected Search Criteria" again and look in the opportunites search, if the z-attributes still missing.

But I can't testing, because at the first step there is something strange, too. Wenn I move the z-attributes from the right to the left side, then the z-attributes is no more on the right side (that's ok), but this z-attribute is also not on the left side. And I don't know why. Then I canceled my plan that I don't loose the z-attribute in the configuration tool.

Prasenjit, I tried to reset the personalization by report, but the report information is: there are no data of personalization.

Do you have any other ideas?

Thank you in advance.

Best regards, Jasmin

Former Member
0 Kudos

Hi,

I have another question to this topic.

When I generated the getter and setter- methods to the z-attributes, the follow getter and setter was generated automatically:

GET_M_(attribute name), GET_I_(attribute name), GET_(attribute name), SET_(attribute name).

I don't know if this is enough, maybe this z-attributes need also the P-Getter. What do you think? Is this necessary?

Best regards, Jasmin

amarnath_kathi
Active Contributor
0 Kudos

Only those methods would be created by default. You can right-click on the variable and generate the P-getter if needed.

Former Member
0 Kudos

Hi,

but do you think that I need the P-getter for solving my problem?

Best regards, Jasmin

Former Member
0 Kudos

Hi,

There is no harm in generating the P-getter but i dont think it is required, pls try to copy the config and then do it again.

Also while moving the fields from left to right or vice-versa click on Show Technical Details and check again for the fields, sometime the z-field doesnt show any label.

Regards,

Shobhit