cancel
Showing results for 
Search instead for 
Did you mean: 

Missing buttons, text, image with skin Signature Design

Former Member
0 Kudos
192

Hello,

I am having a problem when choosing the Signature Design skin when personalising the layout. When I switch to it I get missing buttons, labels and image???... it should look like the display in the attached pic SigDes-Normal.jpg but it looks like that shown in the screenshot SigDes-Missing.jpg.

I have a similar problem with the other skins too, but not as bad as the Signature Design skin.

Can anyone advise me how to correct this?

Thanks

Sophie

Accepted Solutions (1)

Accepted Solutions (1)

kapilpatil
Active Contributor
0 Kudos

Hello Sophie,

Have you done any custom development for skins?

Please can you check the following:

1. Repository for Skins has relevant .css file. See if there were any modifications done in the thtmlb         styles directory. Also check the IE compatible .css files are present for skin 'nova'

2. SICF services for the skin directory paths are active -

         /default_host/sap/bc/kw/mime        

         /SAP/BC/BSP/SAP/thtmlb_styles/sap_skins/nova/

2. SAP note - 2119656 - Readonly textArea uses wrong background color in NOVA skin

                           2027455                Corbu & Nova: F4 Spinning Wheel should display no borde



I hope above helps.

Thanks.

Former Member
0 Kudos

Hi Kapil,

Thanks for your suggestions.

There's been no custom development for skins, and regarding your bullet points see replies below:

Bullet Point (1):

         -  how do I check the skins repository ie is it a directory on the server?

         -  where is the thtmld styles directory?

         -  where do I look for these IE compatible css files for skin nova?

Bullet Point (2):

      -  SICF service /default_host/sap/bc/kw/mime is active

      -  SICF service /default_host/sap/bc/bsp/sap/thtmlb_styles is active (but there is no "sap_skin"s/nova" underneath it???

      - Also I have checked all the SICF services listed in note 1115493 for SAP CRM 7.0 webclient are Active.

The two notes in the last bullet point , I carried out the instructions in the notes but it made not difference.

Thanks

S.

kapilpatil
Active Contributor
0 Kudos

Hello Sophie,

Please find my response below.

       Q-  how do I check the skins repository ie is it a directory on the server?

         Q-  where is the thtmld styles directory?

         Q-  where do I look for these IE compatible css files for skin nova?

A - You can refer skin workbench, spro path given below. Here you can see the .css files for specific IE version and also other related information.

Customer Relationship Management -> UI Framework -> UI Framework Definition -> Skins and Icons -> Access Skin Workbench



      Q-  SICF service /default_host/sap/bc/bsp/sap/thtmlb_styles is active (but there is no "sap_skin"s/nova" underneath it???

A - Apologies, this was a typo error. All skins are tagged under single service.

My questions to understand if this issue is local to one user/machine or global across many users:

I would like know if this issue faced by all users?

Have you tried changing IE browser?

Please refer more information on below links:

Common Issues with IE 11 Browser - CRM - SCN Wiki

Thanks,

Kapil

Former Member
0 Kudos

Hello Kapil,

Well I checked the SPRO path and all the CSS files were there.

I had another thought, maybe it's a Microsoft issue, so I patched the Windows 2008 server right up to the latest patch and great news!.. the Signature Design skin (as well as all the other skins) are now all displaying fine in the webclient ...  I think it was probably a IE patch that fixed the issue.

Thanks again.

Regards

Sophie

Answers (1)

Answers (1)

Former Member
0 Kudos

Anyone have any ideas or ever encountered this issue?

Do you think it's a Microsoft issue not a SAP issue?... the SAP CM 7.0 system is running on Windows enterprise server by the way.

I'd appreciate any suggestions

S