cancel
Showing results for 
Search instead for 
Did you mean: 

middleware errors

Former Member
0 Kudos

hi gurus,

i have some serious problem in middleware, i'm new to this subject, kindly help, all the functionalities were working fine, once the support packs were loaded the middleware is not functioning the way it was,

i have the list of error, the error talks about middleware is not operational, all the queues are stopped, RR queues has stopped its in status hold, error message middleware is not operational, run RR ques, i have done all these process, but i still get these error message when i run MW_check.

No background jobs are running, monitoring tool/statics are not active.

Plz help how to solve these errors,

points will be rewarded.

Regards

jude felix

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Jude,

From your message, it seems that you have problems after the support pack installation and earlier everything was working fine.

Go to SMWP and check were all you have RED lights. Red lights in places like queue stuck is not a show stopper. Thats will not lead to your problem. But check for other RED lights. You are saying that you are getting messages that background jobs are not active. So, activate it through proper node in SMWP. In SMWP, each node has an Analysis button and Execute button. Click those and fix the problem.

For RR queues, got to SMOHQUEUE. "Status of Queue Demon" can be seen there. If the status is not GREEN ( Released), click on that and click the "Release" button. Then release each on the below queues one by one. Everything should be either yellow or green (and not red). Now, start the "Queue demon" by clicking the proper button.

Also, check if there is generic stop for queues (both inbound and outbound) and also in your connected system (eg: R3 system). If there are generic queues, activate it yourself (if you know), otherwise ask the person responsible (your basis person) to do it. One program you can use for this is Report "SMOF_START_QUEUES "

Reward point if this helps. If its still not working, please get back.

Regards,

Alin

Former Member
0 Kudos

Before all this, generate your Middleware objects if your basis person has not done that.

Regards,

Alin

Former Member
0 Kudos

hi all,

thanx for the reply, however, i have done all these process, in RR queues the queue demon is on status hold, after releasing the queue the status turns out to be released and it's in yellow, but when i run the transaction MW_check, it says no generation performed call transaction GN_start, i also ran that particular transaction, and checked in GESTATUS, here we have red and green status, the Red status talks about the industry specific object which says Consumer and Hightech, under this there are some objects which is not generated, SEGMENT_EXTRACT is the function module which does not exist, however, this doesnt give any problems, the RR queues goes back sits as status hold.

it seems like i'm doing the same process but the end result is the same error.

how do i rectify this.

Regards

jude

Former Member
0 Kudos

CHeck NOTE:969076 is relevant and implement.

If you get memo conversion error check note 757126

Former Member
0 Kudos

Hi,

For Resolving that issue Please do the bellow steps.

Goto SMWP Tcode

Drill Down Runtime Information, double click on Message processing, Select the Radio Button On, and save.

Automatically R&R Queue Domino will start and release

SUBCHECK

REALIGN

DEPENDENCY

EXTRACT

EXTRACTBLK

AC_EXTRACT in SMOHQUEUE.

I Think it will solve your problem.

Regards,

Sivasankar.U

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Jude,

Please reffer the below mention SAP Note 637836 - "Error message SMW3065: MW not operational!" if it match with your requirment so only run the report manually mention in the note.

I hope it will solve your problem.

If it works ,so please assign the points.

Regards

Apoorva Asthana

Former Member
0 Kudos

You may want to check SMOGLOG for any MW generation errors and correct them.