cancel
Showing results for 
Search instead for 
Did you mean: 

How to make a field non-Editable in Web UI

Former Member
0 Kudos
1,572

Hello Experts,

I am new to Web UI CRM 7.2. Could anyone pls guide me in making a field non-editable on Web UI.I have the field in one of the custom assignment block. Could you pls guide me with some sample code how to achieve this ?

Thanks in advance.

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi mavrick,

If the field is on a form view, then you can do this directly in the configuration by checking the property 'Display Only'

If the field is on a table view, then you can implement the GET_I_ method of the corresponding field attribute and

set the value rv_disabled = 'TRUE'.

Regards,

Leon

Former Member
0 Kudos

This message was moderated.

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi experts,

For the component 'ICCMP_EMP_SRCH' there is a view 'BUPAEMPSEARCH' , which has 2 context nodes 'CUSTOMER' AND 'SEARCHEMPLOYEE' , i need to add the field 'NICKNAME' which is part of the 'CUSTOMER' context node on the search screen. Currrently all the fields on the screen screen are from the 'SEARCHEMPLOYEE' context node. when i did the configuration , the 'NICKNAME' field is greyed out . I have already generated the Getter ,Setter , GET_I, GET_M methods for the 'NICKNAME' field and the context node and controller class and context class are all active .

on debugging the GET_I method, i see that rv_disabled = 'TRUE' and the current = collection_wrapper->get_current( ) is returning empty value .

for this rv_disabled to be set false , the code below is not triggered since there is no value in current.

IF current->is_property_readonly(

'NICKNAME' ) = abap_false. "#EC NOTEXT

rv_disabled = 'FALSE'.

ENDIF.

when i check for other search fields of context node 'SEARCHEMPLOYEE' , all the fields are set to rv_disabled = 'FALSE'.

can anyone suggest how to approch this. iam i missing any binding between context nodes or any activations ?

The field properties are set as Input field and the display checkbox is not checked.

Former Member
0 Kudos

Hi,

You can make field not editable either in configuration tab of a view by marking it as display only or you can redefine get_I_xxxx method to pass rv_disabled = 'X'.

Regards,

BJ