Showing results for 
Search instead for 
Did you mean: 

ELM file format?

0 Kudos

Hi experts,

I have created a ELM in marketing pro.. The file which i have uploaded not showing the exact reflection in SAP Crm system.

Suggest me which kind of format i need to upload and how the file data should be??

In the process steps also iam getting some errors with Mapping data and Maintain Business partners. Suggest me the solution

for this issue too..

Best Regards,


Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos


You can use either of .CSV or .TXT file format.

Secondly you need to maintain the the input of the file in the same sequence you mentioned in your mapping format. Even if you are skipping a perticular field in the flat file mention as blank and use the  delimiter. Use the same delimiter in your process step.

Note: If you use .txt file you can provide the first field blank but for .csv files i believe if you skip the first field it will make next non-blank column to first column by self. This may be the cause of your issue of not getting the exact reflection in sap crm system.

Follow process step one by one to get the idea at which point issue is happening.

Also for better understanding do the debugging. Below  points are important for debugging:

1. Put an external breakpoint in FM CRM_MKTLIST_WORKFLOW_DEBUG.

2. Go to transaction SU3 and insert a Parameter with ID CRM_DEBUG_CODE and value as MKTLIST.



Former Member
0 Kudos


The file format should be CSV. The mapping format what you created should sync with excel you are uploading.

Lets say if you have Status in Mapping format and Status in your excel, make sure that you give correct technical name  and try.

Make sure that you give all the Mandatory fields required during the Load.

Make sure that you are selecting correct type in Mapping format for Business Partner, Leads, Activities based on the transaction you are performing

Durig the file attaching to ELM and Process, is it saying Mapping Successfull?.

Screenshot will help us determing correct solution for you.

Former Member
0 Kudos


You should use a flat file and the format should correspond to your mapping format, you have to assign the same delimiter while creating new External List which you have used in your file.

First load the file in Mapping Format view and check whether data in load file matches to corresponding fields, also some of the fields like country, language etc you can default the constant value if required.

If you can attach the screnshot of the error or the error messages which you are getting then you might get some clear solution from other forum members.