cancel
Showing results for 
Search instead for 
Did you mean: 

Difference in BP GUID for S4H Customers replicated to CRM.

kamran_farooqui
Contributor
0 Kudos

Dear All,

We have replicated the customers from S4H to CRM and all the customers replicated without any issue. Now when we tried to create any transaction in CRM data is not replicating to S4H showing bdoc error BP with GUID XXXX does not exists.

While checking further I found Customers replicated with different GUID's. While data if we are updating working fine from CRM to S4H and S4H to CRM.

I ran CRMM_BUPA_MAP and clicked Gather information about customer bdoc shows no error but when I click send Business Data it's showing error of E:COM_BUPA:030 XXXXX.

Kindly Advise how to correct the GUID in CRM so that we can have Transactional Data replicated to S4H.

I appreciate early response.

Regards,

Farooq.

michael_piesche
Active Contributor
0 Kudos

kamran.farooqui, please follow up on your open question.

  • comment answers or your question if there are still open issues.
  • otherwise mark an answer as accepted if it helped you solve your problem
  • or post an answer of yourself and accept it if you found another useful solution yourself
  • or redirect your question to another question that is related and was useful to solve your problem
  • in the end, close your question

Accepted Solutions (0)

Answers (1)

Answers (1)

michael_piesche
Active Contributor
0 Kudos

Did you check 'all' relevant mapping tables in CRM and ERP? Where does the mismatch occur?

  • BUT000, CRMM_BUT_CUSTNO (Joined-View CRMV_BUPA_CUSTNO)
  • CRMKUNNR, CRMLIFNR, CRMPARNR
  • CVI_CUST_LINK, CVI_CUST_CT_LINK, CVI_VEND_LINK, CVI_VEND_CT_LINK


Did you check the following, as well as referencing, SAP Notes?

  • 2545498 - Incorrect Business partner GUIDs between ERP and CRM with Active CVI
  • 2704424 - Customer creation results in inconsistent guids between main tables and CRM mapping table
  • 2654430 - Data exchange between the CRM and S4 is not possible as Guid of the Business partners are different in both the systems for the old business partners.
  • 2713963 - FAQ: CVI - Customer Vendor Integration for system conversion to S/4HANA
  • 2231667 - Restrictions for integration of SAP S/4HANA, on-premise edition with SAP CRM
  • 2283810 - Customizing settings for business partner data exchange between SAP S/4 HANA, on-premise edition and SAP CRM
  • 2283695 - Synchronization cockpit generates business partners with wrong GUIDs by ignoring CRM mapping tables
  • 2304337 - Description note for Pre Check Class for Badi implementation CVI_MAPPER
  • 2265093 - S4TWL - Business Partner Approach
  • 2285062 - S4TWL: Business partner data exchange between SAPCRM and S/4 HANA, on-premise edition
  • 2303003 - S4TC BP data exchange between SAP S/4HANA, on-premise edition and SAP CRM: Pre-check class for BAdI implementation CVI_MAPPER

Can you also elaborate more on your setup and problem?

  • ERP and CRM versions
  • CVI settings (direction and number range assignment between BPs and customers in S4)
  • When have the customers been replicated to CRM ('before' CVI, 'during' CVI with direction "customer->bp", or 'after' CVI with direction "bp->customer")
  • Are there BPs in CRM that do not have the issue, e.g. existing customers before, during or after CVI?
  • Did you 'miss' any steps for S4TC (S4 TRANSITION CHECKS - System Conversion Checks for SAP S/4HANA from ECC) or S4TWL (SAP S/4HANA Transition Worklist item)?
  • I assume you also checked the guide for customer vendor integration: SAP S/4HANA Cookbook: Customer/Vendor Integration