cancel
Showing results for 
Search instead for 
Did you mean: 

CRM_UI error :SAP 500 internal server error:: ERROR: Field symbol has not yet been assigned. (termination: RABAX_STATE)

pawan_amarnani
Participant

Hi All,

I got SAP 500 internal server error  given below while loggin into system after executing tcode crm_ui.

ERROR: Field symbol has not yet been assigned. (termination: RABAX_STATE)


following is the dump in ST22:


Category               ABAP Programming Error

Runtime Errors         GETWA_NOT_ASSIGNED

ABAP Program           CL_BSP_RUNTIME================CP

Application Component  BC-BSP

Short text

    Field symbol has not yet been assigned.

What happened?

    Error in the ABAP Application Program

The current ABAP program "CL_BSP_RUNTIME================CP" had to

     terminated because it has

    come across a statement that unfortunately cannot be executed.

Information on where terminated

    Termination occurred in the ABAP program "CL_BSP_RUNTIME========

     in "IF_BSP_RUNTIME~GET_TOKEN".

    The main program was "SAPMHTTP ".

    In the source code you have the termination point in line 27

    of the (Include) program "CL_BSP_RUNTIME================CM01X".

Source Code Extract (Source code has changed)

Line  SourceCde

    1 method IF_BSP_RUNTIME~GET_TOKEN.

    2

    3 *    clear token.

    4 *

    5 *    if me->sec_token is initial.

    6 *      set_token( ).

    7 *    endif.

    8 *

    9 *    c_request->get_cookie( exporting name = 'sap_sec_token'

   10 *                           importing value = token ).

   11   DATA: l_error_text            TYPE string,                "#EC NEEDED

   12         l_message               TYPE string,                "#EC NEEDED

   13         l_subrc                 TYPE string.                "#EC NEEDED

   14

   15   FIELD-SYMBOLS: <text_variable>   TYPE string.             "#EC NEEDED

   16

   17

   18   server->get_xsrf_token( IMPORTING  token = token

   19                           EXCEPTIONS internal_error           = 1

   20                                      called_by_public_service = 2 ).

   21 *  IF sy-subrc <> 0.

   22 *      l_error_text = 'Two GET_XSRF_TOKEN calls led to different values

   23 *      MESSAGE e000(sr) WITH l_error_text.

   24 *  ENDIF.

   25

   26   IF sy-subrc <> 0.

>>>>>     MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno

   28       WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4

   29       INTO <text_variable>.             "#EC NOTEXT

   30     IF <text_variable> IS INITIAL.

   31       l_subrc = sy-subrc.

   32       CONCATENATE  'Class CL_BSP_RUNTIME Method GET_TOKEN SY-SUBRC = ' l

   33       INTO <text_variable> .

   34     ENDIF.

   35 *  ...  "passing the error message to the upper / UI layer

   36

   37   ELSE.

   38     me->sec_token = token.

               ENDIF.

            endmethod.


Please help me.


Thanks,

Pavan

Accepted Solutions (0)

Answers (7)

Answers (7)

Neelakantara
Discoverer

I tried SECSTORE --> execute --> make sure to delete all the error entries

Once done, it should work.

Amit91
Participant
0 Kudos

This one helped me to fix the "CRM_UI error :SAP 500 internal server error".

Please also note that at the time of writing this answer IE is phased out and only Chromium based/Firefox browser are existing. Check that SAP_UI component shall be at 754 or above level to avoid USER-AGENT detection error. In worst case, use the user-agent switcher add-ins from the chrome/edge market place or try out Firefox.

former_member246171
Discoverer
0 Kudos

The dump "Field symbol has not yet been assigned" or "GETWA_NOT_ASSIGNED" in webgui UI ocurrs usually  in case of client copy/system refresh.

Please try to migrate sec store entries.

Go to Tcode SECSTORE and switch to the "System data changed" tab.

Fill the following fields : "Old system name", "Old installation number" and "SAP release key" and click"Execute".

Regards,

Dinesh Subramaniyan.

Harley-Davdison SAP Basis consultant|Chennai

Former Member
0 Kudos

Hi Dinesh thank you for reply.....

I am using SAP CRM EHP 3 system,

I am unable to see Fields: "Old system name", "Old installation number" and "SAP release key"

in the TC = SECSTORE

Former Member
0 Kudos

Facing same issue :

SAP 500 internal server error:: ERROR: Field symbol has not yet been assigned. (termination: RABAX_S...

Runtime Errors - GETWA_NOT_ASSIGNED, ABAP Program -        CL_AXT_TABLES_BUFFER==========CP, Application Component - CA-GTF-EEW

former_member246171
Discoverer
0 Kudos

Issue resolved after correcting rsec* tables.

Regards,

Dinesh Subramaniyan

GopalakrishnanS
Participant
0 Kudos

Hi Dinesh,

Can you provide your solution in detail. You have mentioned correcting rsec* tables. Which tables and what correction has to be done to resolve this issue.

It will help our fellow SCN members if they face the same issue.

Thanks & Regards,

Gopalakrishnan Selvaraj.

Former Member
0 Kudos

Dear Pawan,

I have found a solution on my part when getting this error. Please check in SICF if you have configured your "External Aliases" correctly. See that you haven't entered too many info in the 'Logon data' tab for the higher virtual hosts.

In my case I had entered the RFCUSER + password under the default_host which gave this error. I have now changed it to only have the client and set the procedure to "Standard' and I can start transaction crm_ui without any problems.

Kind regards,

Thomas

Former Member
0 Kudos

Hey Pawan,

Have you found a solution for this? I'm currently experiencing the exact same problem and the other linked forum-threads do not contain a solution.

Same HTTP 500 error with the RABAX_STATE termination and on the same IF_BSP_RUNTIME~GET_TOKEN

|   22|  server->get_xsrf_token( IMPORTING  token = token                                          |
|   23|                             EXCEPTIONS internal_error           = 1                        |
|   24|                                     called_by_public_service = 2 ).                        |
|   25|*  IF sy-subrc <> 0.                                                                        |
|   26|*      l_error_text = 'Two GET_XSRF_TOKEN calls led to different values !'. "#EC NOTEXT     |
|   27|*      MESSAGE e000(sr) WITH l_error_text.                                                  |
|   28|*  ENDIF.                                                                                   |
|   29|                                                                                            |
|   30|  IF sy-subrc <> 0.                                                                         |
|   31|  MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno                                         |
|>>>>>|    WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4                                                |
|   33|    INTO <text_variable>.             "#EC NOTEXT                                           |
|   34|  IF <text_variable> IS INITIAL.                                                            |
|   35|    l_subrc = sy-subrc.                                                                     |
|   36|    CONCATENATE  'Class CL_BSP_RUNTIME Method GET_TOKEN SY-SUBRC = ' l_subrc                |
|   37|    INTO <text_variable> .                                                                  |
|   38|  ENDIF.                                                                                    |
|   39|*  ...  "passing the error message to the upper / UI layer                                  |
|   40|                                                                                            |
|   41|    ELSE.    

Former Member
0 Kudos

Hi Thomas,

Please check if the message text is showing any information about services.Go to SICF and check if those services are not enabled, Enable them if they are not yet enabled, this may resolve the issue.

Regards

Jayasri

Former Member
0 Kudos

I have already checked that all services are active in SICF according to note 1115493 as well as those mentioned in the best practices. I have also already added a link in RZ10 for icm/host_name_full as well.

kumar5
Active Contributor
0 Kudos

Hi,

check below threads

https://scn.sap.com/thread/2094900

Thanks,

Kumar.