cancel
Showing results for 
Search instead for 
Did you mean: 

CRM Pricing does not pick plant information

Former Member
0 Kudos

Hi,

We have downloaded ECC 6.0 plants into CRM 5.0 system . The table

CRMM_LOCMAP is correctly filled with the plant entries. Now I tried to

create a sales order in CRM . The plant(vendor) value is correctly determined

from the ATP check .

I have a pricing table CNCCRMPRCUS708 which has Sales area/plant/

material combination and condition records are maintained for the

plant.

However, during creation of sales order , plant is not used to find the

condition record. I have checked the note 493947 which talks about

settings for plant download. However the validity mentioned is 3.0 (in

the subject of the note).

In the pricing trace , the INVENT_LOC attribute value is set

as '00000000000000.....' for PR00 condition type

Please let me know what I need to do and also if the note 493947 is to

be applied.

Regards,

Pradeep

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Pradeep,

Have you entered Value for Partner Funtion '00000019 Vendor' in your sales order.

Material guid will be determined once INVENT_LOC is determined.

Pls do the same, save order and check if pricing is determined.

Else apply note:

513884 - CRM 3.0: Automatic Vendor determination in sales order

Best Regards,

Pratik Patel

<b>Reward with Points!</b>

Former Member
0 Kudos

Pratik,

As already said Vendor determination is not a problem, the ATP check brings the vendor correctly in the line item. The problem is with the pricing condition. To check i also entered the partner function "00000035 Vendor" and tried but still same error.

Note mentioned by you is not relavent because the vendor determination is happening correctly.

This is something to do with pricing and conditions.

Regards,

Pradeep

Former Member
0 Kudos

I realise that this is a very old post, but I am experiencing a similar issue. I cannot pick up prices where the condition table contains 'Plant' as a key. I think that Plant is derived from Material master data, and I do see Plant information in the Materials master data. Any ideas?

Regards,

Simon.

Former Member
0 Kudos

Hi Pradeep,

To determine the conditions you need to do following things:

1st: From CRMM_LOCMAP determine the business partner mapped against the required plant.

2nd: In the Sales Order for Partner Funtion Vendor enter the Business partner determined in step 1.

Check if pricing is determined.

If it doesnot help apply note

513884 - CRM 3.0: Automatic Vendor determination in sales order

Best Regards,

Pratik Patel

<b>Reward with Points!</b>

Former Member
0 Kudos

Pratik,

The CRMM_LOCMAP table is filled correctly. The EXT_LOCNO is <b>SAS1</b> and the corresponding PARTNER_NO is <b>0000006</b>. The ATP check correctly picks this partner number when i enter the material in the line item.

But during Pricing the condition is not picked correctly. When I select the Item Conditions - Accesses, the access fails for condition CNCCRMPRCUS708. Under this access I see the attributes SALES_ORG, DIS_CHANNEL and DIVISION is picked correctly. The problem occurs in the attribute INVENT_LOC where the AttributeClassValue is shown as 00000000000000000000000000000000 instead of the correct guid. Also I see that the material attribute is not seen at all. The CondTableDesc is <b>Sales org./Distr. Chl/Division/Plant/Material</b>.

Can you please let me know if any settings could be missing that could lead to this problem?

Regards,

Pradeep