cancel
Showing results for 
Search instead for 
Did you mean: 

Clean 5.3.0.2 install on mysql gives initialisation error

Former Member
0 Kudos

The initialisition error:

 Table 'hybris.pcp2wrtblecvrel' doesn't exist

It's a clean developer install of the full 5.3.0.2 commerce suite, the mysql schema is initialised as follows:

 CREATE USER 'hybris'@'localhost' IDENTIFIED BY ‘hybris’;
 CREATE DATABASE hybris DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;
 GRANT ALL ON hybris.* TO 'hybris'@‘localhost’;
 flush privileges;

The local.properties config for mysql:

 db.url=jdbc:mysql://localhost/hybris?useConfigs=maxPerformance&characterEncoding=utf8
 db.driver=com.mysql.jdbc.Driver
 db.username=hybris
 db.password=hybris
 db.tableprefix=
 db.customsessionsql=SET SESSION TRANSACTION ISOLATION LEVEL READ COMMITTED;
 mysql.optional.tabledefs=CHARSET=utf8 COLLATE=utf8_bin
 mysql.tabletype=InnoDB
 mysql.allow.fractional.seconds=true

Version info:

  • hybris-commerce-suite-5.3.0.2

  • OpenJDK7u71-2.5.3-0ubuntu0.14.04.1

  • Mysql Server 5.5.40-0ubuntu0.14.04.1

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

I have just finished initializing a clean installation of hybris 5.3.0.2 on both, HSSQL and MySQL with your setup.

Everything is working fine.

Please consult Third-party Compatibility information because you seem to be using unsupported java version. Also check JDBC driver version.

Best regards,

Former Member
0 Kudos

Thanks for testing it with my config, then I at least know that's not the problem. I'm gonna start with trying the supported Oracle JDK 7.

Former Member
0 Kudos

Ok, actually didn't start with the JDK but tried bumping the mysql version to 5.6 and now the init works fine :-). So for some reason my 5.5 version was giving problems, thanks again for confirming nothing was wrong with my config.

Former Member
0 Kudos

Actually, I have re-tried your test with same version of MySQL as you did and you were right! An error occurs. It is caused by mysql.allow.fractional.seconds=true setting!

If you consult project.properties than this setting is commented with following line: ## Set this property to true if MySQL 5.6.4 or later is used. It allows to create datetime columns which support

You can read more about it in following link:

https://wiki.hybris.com/display/release5/Include+-+projectproperties+-+MySQL+parameters

Misconfiguration 🙂

Best regards,

Former Member
0 Kudos

Alright, then it all makes sense. Thanks for the help!

Answers (2)

Answers (2)

Former Member
0 Kudos

HI Nick,

As Marek said, it seems to be working fine with OOTB platform.

Regards

Michał Stysło

Former Member
0 Kudos

Hi Nick,

I'm doing a test on my local OOTB platform and I'll let you know the results

Michał Stysło