cancel
Showing results for 
Search instead for 
Did you mean: 

Classification attributes are not showing in Backoffice after migrating from 5.3 to 6.5

Former Member
0 Kudos

Classification attributes are shown in HMC but not shown in Backoffice.(6.5). Please suggest.

INFO | jvm 1 | main | 2017/11/20 14:19:54.683 | INFO [backofficeSolrIndexerDeleteCronJob::de.hybris.platform.servicelayer.internal.jalo.ServicelayerJob] (backofficeSolrIndexerDeleteCronJob) [CronJobAdvice] Replacing CronJob#sendEmail method to get better control over email INFO | jvm 1 | main | 2017/11/20 14:20:04.487 | ERROR [hybrisHTTP3] [UiEngineImpl] INFO | jvm 1 | main | 2017/11/20 14:20:04.487 | java.lang.IllegalArgumentException: Parameter 'type' cannot be null! INFO | jvm 1 | main | 2017/11/20 14:20:04.487 | at com.google.common.base.Preconditions.checkArgument(Preconditions.java:122) ~[guava-21.0.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.487 | at de.hybris.platform.servicelayer.util.ServicesUtil.validateParameterNotNull(ServicesUtil.java:138) ~[coreserver.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.487 | at de.hybris.platform.classification.impl.DefaultClassificationSystemService.getUnitsOfTypeForSystemVersion(DefaultClassificationSystemService.java:154) ~[classes/:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.488 | at de.hybris.platform.platformbackoffice.classification.editor.FeatureValueEditor.findAllApplicableUnits(FeatureValueEditor.java:151) ~[?:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.488 | at de.hybris.platform.platformbackoffice.classification.editor.FeatureValueEditor.prepareUnitSelector(FeatureValueEditor.java:107) ~[?:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.488 | at de.hybris.platform.platformbackoffice.classification.editor.FeatureValueEditor.render(FeatureValueEditor.java:83) ~[?:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.488 | at com.hybris.cockpitng.components.Editor.renderEditor(Editor.java:452) ~[cockpitframework-6.5.0.2-RC2.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.488 | at com.hybris.cockpitng.components.Editor.buildEditor(Editor.java:390) ~[cockpitframework-6.5.0.2-RC2.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.489 | at com.hybris.cockpitng.components.Editor.initialize(Editor.java:276) ~[cockpitframework-6.5.0.2-RC2.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.489 | at com.hybris.cockpitng.components.Editor.afterCompose(Editor.java:185) ~[cockpitframework-6.5.0.2-RC2.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.489 | at de.hybris.platform.platformbackoffice.classification.editor.FeatureEditor.render(FeatureEditor.java:74) ~[?:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.489 | at com.hybris.cockpitng.components.Editor.renderEditor(Editor.java:452) ~[cockpitframework-6.5.0.2-RC2.jar:?] INFO | jvm 1 | main | 2017/11/20 14:20:04.489 | at com.hybris.cockpitng.components.Editor.buildEditor(Editor.java:390) ~[cockpitframework-6.5.0.2-RC2.jar:?]

Accepted Solutions (1)

Accepted Solutions (1)

former_member632755
Active Contributor
0 Kudos

Hi,

the attached log is not enough to figure out what may be the reason. As this seems to be very much related to the migration and therefore I suggest asking our support for dedicated help.

Cheers, Wojtek

Former Member
0 Kudos

Got the solution: For "ClassificationAttributeUnit" attribute "unitType" was missing. Looks like in newer Hybris versions unitType is mandatory was not in 5.3

Answers (0)