cancel
Showing results for 
Search instead for 
Did you mean: 

Can not stop hybris server 6.4 in cygwin/babun

Former Member
0 Kudos

Hello,

I am using cygwin/babun in Windows due to various reasons (proxy setup, linux commands, etc)

I can start the hybris server with

» ./setantenv.bat
Setting ant home to: D:\sac-hybris\hybris\bin\platform\apache-ant-1.9.1
Apache Ant(TM) version 1.9.1 compiled on May 15 2013
» ./hybrisserver.bat

I am facing the problem that I am not able to stop the hybris server and I get a weird error message.
» ./hybrisserver.bat stop

FATAL | wrapper | Failed to load configuration: D:\SAC-HY~1\hybris\bin\platform\tomcat\bin\"
A console does not exist. Disabling direct console output and falling back to using pipes.

STRG+C does not kill and de-attached the console only. The server continues in the background.

Any suggestions?

Accepted Solutions (0)

Answers (9)

Answers (9)

Former Member
0 Kudos

okay!!! Thanks Pablo

Former Member
0 Kudos

Has It worked? Can you vote the correct answer? Bye

Former Member
0 Kudos

yes it's working but we have to change in path which is given in wrraper.bat

set _WRAPPER_CONF="%_YWRAPPER_CONF%"

Former Member
0 Kudos

Hybris doesn't explain how install a service in windows, but you can follow any tutorial. You must install this bat:

\hybris\bin\platform\tomcat\bin\wrapper.bat

You error file said: "Failed to load configuration", Check if this file configuration is correct (java version, paths, ...)

\hybris\bin\platform\tomcat\conf\wrapper.conf

Former Member
0 Kudos

Any other path setting for wrapper.conf???

Former Member
0 Kudos

Initialization previously i have done, but there is no custom configuration in local.properties

Former Member
0 Kudos

Hi Pablo,

In windows when i run D:\Hybris_6.4\hybris\bin\platform\tomcat\bin>InstallTomcatService.bat then it's giving below error.

D:\Hybris_6.4\hybris\bin\platform\tomcat\bin>InstallTomcatService.bat FATAL | wrapper | Failed to load configuration: D:\Hybris_6.4\hybris\bin\platform\tomcat\bin\"

D:\Hybris_6.4\hybris\bin\platform\tomcat\bin>

what other configuration require for this.

Regards Rajesh

Former Member
0 Kudos

Have you done initialization? Do you have a custom configuration in local.properties?

Former Member
0 Kudos

Hi,

I don't know how cygwin/babun works, but if you can't execute ./hybrisserver.bat start you can't simulate linux behaviour.

In windows there is a .bat to create a service, and then running hybris in background and handle it from control panel/administrative tools/services

You must use this bat: \hybris\bin\platform\tomcat\bin\InstallTomcatService.bat

Former Member
0 Kudos

Hi Pablo, I can't start hybris with ./hybrisserver.bat start, this results in the following error:

FATAL | wrapper | Failed to load configuration: D:\SAC-HY~1\hybris\bin\platform\tomcat\bin\"
A console does not exist. Disabling direct console output and falling back to using pipes.

Former Member
0 Kudos

hi,

if you want use ./hybrisserver.bat stop you must start hybris with ./hybrisserver.bat start (in background).

To see the logs in console you can use # tail -f xxxx\consoloe.log

eric_rosfelder
Explorer
0 Kudos

It's not a "standard" stop, but you can do "CTRL + C"

Former Member
0 Kudos

Hi Eric, thank you for your response. This was my first idea and here it gets weird in cygwin/babun CTRL+C does NOT kill the process. The server continues in the background and the log messages pop-ups. STRG+C de-attaches the console only and does NOT kill it. I didn't see this problem before in cygwin/babun.