cancel
Showing results for 
Search instead for 
Did you mean: 

BAPI_BUSPROCESSND_CREATEMULTI

Former Member
0 Kudos

Hello,

Can someone help me with this problem ?

I use the bapi BAPI_BUSPROCESSND_CREATEMULTI to create a service order.

The service order is created but the item IBASE is not fillled.

How can i give the Ibase thru the bapi and in which parameter of the bapi i have to fil this.

may someone has an example of an abap which create a serviceorder by calling the function BAPI_BUSPROCESSND_CREATEMULTI

Thanks

Jo Adams

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi there,

I've a simmilar requirement where i've to create a sales order in crm using bapi, i'm using the FM BAPI_BUSPROCESSND_CREATEMULTI. which comes out without giving error. but no records are insereted in the table. I've used bapi commit also.

if you are through with your requirement, can u send me your code for reffereence.

Thanxs

Sanju

Former Member
0 Kudos

Hello everybody!

I'm fascing exactly the same problem right now... I've got my BAPI invoked and everything but the iBASE insertion is working fine here...

CRM contract is created, but no PoD in the objects tab!!

These are the paramenters I'm filling:

  • iBase OBJECTS

  • Input fields

wa_input_fields-objectname = 'ORDPRP_I'.

wa_input_fields-ref_kind = 'D'.

wa_input_fields-ref_handle = '0000000002'.

wa_input_fields-fieldname = 'IBASE_COMPONENT'.

APPEND wa_input_fields TO int_input_fields.

wa_input_fields-fieldname = 'IBASE_HEADER'.

APPEND wa_input_fields TO int_input_fields.

wa_input_fields-fieldname = 'PRODUCT_ID'.

APPEND wa_input_fields TO int_input_fields.

  • Objects

wa_objects-ibase_component = wa_ibin-instance.

wa_objects-ref_handle = '0000000002'.

APPEND wa_objects TO INT_objects.

Can any of you tell me why is my contract being created with no PoD?

Thanks in advance! Best reagrds!!

Former Member
0 Kudos

Hi there,

I've a simmilar requirement where i've to create a sales order in crm using bapi, i'm using the FM BAPI_BUSPROCESSND_CREATEMULTI. which comes out without giving error. but no records are insereted in the table. I've used bapi commit also.

if you are through with your requirement, can u send me your code for reffereence.

Thanxs

Sanju

Former Member
0 Kudos

Hi there,

I've a simmilar requirement where i've to create a sales order in crm using bapi, i'm using the FM BAPI_BUSPROCESSND_CREATEMULTI. which comes out without giving error. but no records are insereted in the table. I've used bapi commit also.

if you are through with your requirement, can u send me your code for reffereence.

Thanxs

Sanju